Help Does MediaLibrary now only process if we install filebot?

Qbox

Passing Basics
Beginner
Apr 27, 2017
8
0
1
QNAP
TS-x53D
Ethernet
1 GbE
I brought rtorrent agian here a few month ago, but installed the new version just now. I can't enable mediaprocessing, checkmark always disappears and no processing done.
I only need this for file renaming and movin, for this I edited the filbot_processing.sh in the past. So that no NFO files were generated and no metadata is downloaded. But now nothing is working. So do I need to install filebot for simple file renaming?

Thx
 

Damian

Enterprise Admin...
Q's Architect
Jan 22, 2016
522
2
94
28
QNAP
TVS-x71
Ethernet
802.11ad
If I not mistake new rtorrent has build in filebot so no need to extra install it. What you have in settings:
1663264038540.png

Any intersting errors in: /share/Rdownload/logs/medialib.log?
 

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,579
18
1,918
153
37
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
Yes well, there is a trick about this.
After you select checkbox "Enable media library..." and then hit Save settings buttons it will remain unselected, but rtorrent will still process medialibrary - even if in the settings it is not selected.
However in future releases you may expect there will be no filebot included anymore so you will have to use external filebot.
Download: Filebot

filebot-available: Rtorrent-Pro reports: Filebot not found. Please install java and filebot correctly: https://www.filebot.net/forums/viewtopic.php...
 

Qbox

Passing Basics
Beginner
Apr 27, 2017
8
0
1
QNAP
TS-x53D
Ethernet
1 GbE
Thx for the fast reply.
I will check that log but I think there must be a issue than. Cause if I check "Automatically organize downloaded media content", this checkmark doesn't get saved.

EDIT: After I post this I saw your reply @Silas thank you
 

Qbox

Passing Basics
Beginner
Apr 27, 2017
8
0
1
QNAP
TS-x53D
Ethernet
1 GbE
Ok, installed all recommended qpks but now it says in the medialib.log unrar failed for all files tested. No problem with old version.

If I unpack files manually from within rtorrent itself, unpacking is done without problems.

EDIT: So it seems unrar is broken in 4.9.6 version of filebot according their forums.
EDIT2: Also not working with filebot 4.9.8 (beta)

Well I think I will stick with the old rtorrent version, payed twice nothing working and with the new version need to install two apps (which I don't want even not signed digitally etc. etc. etc...

Where can I find a download for the 900 build if I dont want to install the qnapclub version ?
 

Qbox

Passing Basics
Beginner
Apr 27, 2017
8
0
1
QNAP
TS-x53D
Ethernet
1 GbE
Installed old version of rtorrent (build 900) again and all is working like it should be. Without installing filebot and java.
So for me this is a really bad experience. Paid over here at qnap.pl a few month ago to get access to the new build of rtorrent (which is a nice application). But with broken medialibrary processing and the need to have two extra apps installed which even not working correctly, I'm really not happy.

EDIT: Checked again, installed BB01 using newest qts 5.0.1 stable and unrar is not working with included filebot and also not with external. In medialib.log unrar always fail with message "unrar failed (7)" .
 

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,579
18
1,918
153
37
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
I see you are dissapointed. But I think you dont understand that part about Filebot. Filebot is not Rtorrent-Pro product and it was only introduced in the past as an solution to process media files automatically. Filebot will not be included anymore in future releases of Rtorrent-Pro, but Rtorrent-Pro will still support for Filebot if its installed.
However if you experience Filebot issues please read once again:
filebot-available: Rtorrent-Pro reports: Filebot not found. Please install java and filebot correctly: https://www.filebot.net/forums/viewtopic.php...
So if the Filebot is not our product you have to read documentation of Filebot first.
You can try to edit /usr/bin/filebot
Bash:
...
P7ZIP="/usr/local/sbin/7z"
UNRAR="/usr/local/sbin/unrar"
...
and replace with:
Bash:
...
P7ZIP="/usr/bin/rtorrent/bin/7z"
UNRAR="/usr/bin/rtorrent/bin/unrar"
...
This is how Filebot was used in the past.
Nothing else was changed. All other questions goes to Filebot author.
 

Qbox

Passing Basics
Beginner
Apr 27, 2017
8
0
1
QNAP
TS-x53D
Ethernet
1 GbE
Yeah a little disappointed. But thank you again for your help. Will look into your suggested solution as soon as I update rtorrent pro again.