Udzielamy pomocy Jak długo trwa synchronizacja dysku(ów)?

Dyskusja w 'Macierz oraz woluminy dyskowe' rozpoczęta przez użytkownika Drib, 7 Wrzesień 2017.

Ładowanie...
  1. Drib
    Offline

    Drib Nowy użytkownik Noobie

    Dołączył:
    2 Wrzesień 2017
    Wiadomości:
    2
    Local Time:
    12:20
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-412
    Ethernet:
    null
    TS-412 null
    Witam wszystkich uczestników forum.

    Jestem tu od niedawna i to mój pierwszy wpis - właściwie drugi po przywitaniu się :)
    Tak jak w tytule - ile czasu (godzin) może zająć synchronizacja dysków - dla RAID6? Dyski to 4 szt. 2 TB Seagate ST2000DL003-9VT1CC3C.
    Zdecydowałem się na RAID6 gdyż dyski już wg SMART mają już ok. 50% życia za sobą stąd powinno być trochę bezpieczniej z danymi przy takiej macierzy.
    Kilka dni temu zacząłem swoją przygodę z QNAP, odkupując używany model TS-412 wraz z tymi dyskami.
    Po wstępnych zabiegach kosmetycznych (NAS był nieco przykurzony) - twardy reset, aktualizacja firmware do najnowszego i zabawa w konfigurację i uruchamianie.

    Pierwsza próba zakładania RAID6 skończyła się na ok 6% (po ok 7 godzinach) - z NAS'a zaczęły dobiegać dziwne piski i wyskoczył komunikat, że dysk nr 3 został zdegradowany - zgasła też zielona dioda nad kieszenią z tym dyskiem.
    Przerwałem operację, uruchomiłem ponownie NAS'a - i ponownie wszystkie dyski były widoczne. Przetestowałem je po kolei - każdy poprawnie przeszedł test. Wyjąłem dyski i na zewnętrznej stacji dokującej każdy dysk został sprawdzony (m.in. HD Tune - dokładny test) - wszystko odbyło się bez jakichkolwiek problemów. Wszystkie cztery HDD są OK.
    Zresztą dyski mimo swojego przebiegu zbytnio się nie napracowały - wiem gdzie pracował ten NAS - robił za zapasowy magazyn danych, w dobrze utrzymanej serwerowni (klima, itd).
    Po ponownym zamontowaniu dysków w kieszeniach (w poprawnej kolejności) proces zakładania macierzy RAID6 rozpocząłem od nowa.
    Mimo, że nie zmieniałem nic w konfiguracji - te same usługi pracują w tle - to jak na razie proces przebiega dość sprawnie. Aktualnie po ok. 4 godzinach mam już 9% synchronizacji.
    Oczywiście status wszystkich dysków za każdym razem jest OK. Test SMART pokazuje, że dyski są w dobrym stanie.

    Ciekawi mnie ile może taka synchronizacja potrwać? NAS nic innego poza tym nie robi. Pliki zacznę dopiero kopiować po zakończeniu synchronizacji macierzy. Prosta proporcja wskazuje na ponad 40 godzin (przy aktualnym tempie). Gdyby zaś brać pod uwagę poprzednie tempo - to nawet wychodzi prawie 5 pełnych dób. Czy zawsze ten proces tyle trwa? Co będzie jak w tym czasie zabraknie zasilania? NAS wprawdzie podpięty jest pod UPS i został skonfigurowany, ale mieszkam poza miastem i braki prądu rzadko bo rzadko, jednak zdarzają się.
    I jeszcze - jaki mógł być powód, że za pierwszym razem wyskoczył ww. komunikat i do tego synchronizacja tych 6% trwała dłużej niż aktualnie?

    ---------------------------------------------------------------------------------------------------
    Wersja oprogramowania Firmware: 4.3.3.0299 Build 20170901
    Model serwera: QNAP TS-412
     
  2. pigers
    Online

    pigers GOD's left hand - careful - he don't care anymore. Administrator

    Dołączył:
    26 Lipiec 2013
    Wiadomości:
    5 610
    Miejscowość:
    Nysa
    Local Time:
    12:20
    Oceny:
    +1 012 / 28 / -12
    Followers:
    2
    QNAP:
    TS-x53
    Synology:
    huh ? I do not collect crap
    Ethernet:
    1 GbE
    TS-x53 1 GbE
    polecam wyłaczyć zbędne usługi i czekać cierpliwie, ten nas ma 256 MB RAM i cpu arma więc demonem szybkości on nie jest :)
     
  3. Drib
    Offline

    Drib Nowy użytkownik Noobie

    Dołączył:
    2 Wrzesień 2017
    Wiadomości:
    2
    Local Time:
    12:20
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-412
    Ethernet:
    null
    TS-412 null
    Mam praktycznie wszystko wyłączone - status systemu pokazuje, że włączone są jedynie: 'sieć Microsoft', 'zarządzanie multimediami' i 'serwer rsync'. Reszta powyłączana.
    Trochę przyspieszyło - mam już 19% w niecałe 8 godzin :)

    Jak widać - muszę się uzbroić w cierpliwość...
    Napiszę potem ile czasu zajęło to mojemu NASikowi.
    --- Połączono posty, 9 Wrzesień 2017, Data oryginalnego postu: 7 Wrzesień 2017 ---
    I wracam... :) z informacją o czasie synchronizacji nowej macierzy RAID6 pod TS-412
    Całość zakończyła się wczoraj przed północą, czyli cały proces trwał 38,5 godziny. W tym czasie, oczywiście praca na nasie była utrudniona - komfort żaden i dodatkowo spowalniało synchronizację. Obciążenie procka blisko 100%, RAM ok. 60-80%.
    Co ciekawe - na początku synchronizacja przebiegała wolniej (z obliczeń wychodziło, że potrwa ponad 40h) a z czasem przyspieszyła.

    Zabieram się do użytkowania :)
     
  4. pigers
    Online

    pigers GOD's left hand - careful - he don't care anymore. Administrator

    Dołączył:
    26 Lipiec 2013
    Wiadomości:
    5 610
    Miejscowość:
    Nysa
    Local Time:
    12:20
    Oceny:
    +1 012 / 28 / -12
    Followers:
    2
    QNAP:
    TS-x53
    Synology:
    huh ? I do not collect crap
    Ethernet:
    1 GbE

Poleć tę stronę