Solved Jak wyłaczyć phpPgAdmin

selekta

Entry Technician
Q Associate
Nov 14, 2018
56
5
8
36
QNAP
HS-251
Ethernet
1 GbE
Witam posiadam starszą paczkę qpkg w moim qnapie, chciałbym wyłączyć phpPgAdmin permanentnie, usunąłem cały folder z phpPgAdmin jednak po restarcie jest tam znowu - stworzony przez system, czy ktoś zna sposób na wyłączenie tego cuda? baza danych (postgres) oczywiście jest mi potrzebna jednak to kompletnie mi zawadza.

[TS-253A]
 

pigers

Zawsze pytaj Silasa - wie lepiej bo ma ESXi
Administrator
Jul 26, 2013
12,803
5
2,043
230
www.buymeacoffee.com
QNAP
null
Ethernet
100 GbE
edytuj /etc/config/qpkg.conf za pomocą edytora
znajdź sekcję z w/w programem - i zmień "Enabled" na przeciwną wartość
wsio
 

selekta

Entry Technician
Q Associate
Nov 14, 2018
56
5
8
36
QNAP
HS-251
Ethernet
1 GbE
Code:
[PostgreSQL]
Name = PostgreSQL
Status = complete
Build = 20170905
Version = 9.3.13.3
Author = QNAP Systems, Inc.
QPKG_File = PostgreSQL.qpkg
Date = 2019-11-20
Shell = /share/CACHEDEV1_DATA/.qpkg/PostgreSQL/PostgreSQL.sh
Volume_Select = 3
Install_Path = /share/CACHEDEV1_DATA/.qpkg/PostgreSQL
WebUI = /phpPgAdmin/
RC_Number = 101
Timeout = 180,180
Enable = TRUE
Official = 0

czy o to miejsce chodzi? nie wyłączę całego postgresa?
 

pigers

Zawsze pytaj Silasa - wie lepiej bo ma ESXi
Administrator
Jul 26, 2013
12,803
5
2,043
230
www.buymeacoffee.com
QNAP
null
Ethernet
100 GbE
no fakt - patrząc na składnie .. to wyłączy całego Postgre

popatrz do pliku "/share/CACHEDEV1_DATA/.qpkg/PostgreSQL/PostgreSQL.sh" może tam coś cię naprowadzi
 

selekta

Entry Technician
Q Associate
Nov 14, 2018
56
5
8
36
QNAP
HS-251
Ethernet
1 GbE
Fakt tam jest linijka która to cudo instaluje, dzięki za podpowiedź.
 
  • Like
Reactions: pigers

selekta

Entry Technician
Q Associate
Nov 14, 2018
56
5
8
36
QNAP
HS-251
Ethernet
1 GbE
W sekcji create_link(){
wystarczyło zakomentować linię
/bin/ln -s ${QPKG_INSTALL_PATH}/web /share/${APACHE_ROOT}/phpPgAdmin,
to działanie było odpowiedzialne za ponowną instalację GUI, jeśli GUI zostało usunięte
 
  • Wow
Reactions: jerry1333