Rozwiązany Kilka serwerów ftp pod tym samym adresem IP

Dyskusja w 'Zdalny dostęp oraz sieć komputerowa' rozpoczęta przez użytkownika milwis, 8 Sierpień 2018.

Ładowanie...
Tagi:
  1. milwis
    Offline

    milwis Nowy użytkownik Noobie

    Dołączył:
    24 Sierpień 2017
    Wiadomości:
    7
    Local Time:
    14:25
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x69 Pro
    Ethernet:
    1 GbE
    TS-x69 Pro 1 GbE
    Witam.

    Mam problem z podłączeniem się za pomocą windows explorera w windows 10 z serwerem FTP, który postawiony jest na porcie 2099. Na tym samym IP stoi już jeden serwer FTP na porcie 21. Z tym drugim na 2099 mogę bez problemu połączyć się przez przeglądarkę i wszystko działa jak należy ale gdy próbuje go dodać jako miejsce sieciowe w eksploratorze to wywala mi błąd
    Innymi słowy windows ma problem z podłączeniem do serwerów na innym porcie niż 21. Czy ktoś wie jak rozwiązać ten problem?

    Wersja oprogramowania Firmware: 4.3.3 Build 20180725
    Model serwera: QNAP TS-469 PRO
     
  2. milwis
    Offline

    milwis Nowy użytkownik Noobie

    Dołączył:
    24 Sierpień 2017
    Wiadomości:
    7
    Local Time:
    14:25
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x69 Pro
    Ethernet:
    1 GbE
    TS-x69 Pro 1 GbE
    Drugi pojawiający się czasami błąd to
    Nie pamiętam dokładnie ostatniej linijki także może się troszkę różnić ale na pewno kod błędu to 227
    --- Połączono posty, 8 Sierpień 2018, Data oryginalnego postu: 8 Sierpień 2018 ---
    Kolejna informacja:
    W przypadku gdy próbuje połączyć się po porcie 2099 to dostaje komunikat z post nr 1.
    Gdy po porcie 2100 ( ten działa w przeglądarce oraz programach typu WinSCP) dostaje info z postu drugiego.
    Na jednym z anglojęzycznych forów znalazłem rozwiązanie problemu z tym komunikatem poprzez zmianę ustawienia o nazwie w QNAP "odpowiadaj zewnętrznym IP na zapytania połączeń FTP z trybem pasywnym". Należało to włączyć i podać rzeczywiste zewnętrze IP. Po zrobieniu tego dostaje komunikat:
    --- Połączono posty, 8 Sierpień 2018 ---
    Działa.
    Należało w ustawieniu powyżej tj zakres portów pasywnych zdefiniować pewien zakres, który da się przekierować na Waszym routerze, a następnie go właśnie przekierować.

    Temat do zamknięcia, mam nadzieję, że komuś się przyda.
     
  3. Silas Mariusz
    Offline

    Silas Mariusz SysOp Administrator

    Dołączył:
    5 Kwiecień 2008
    Wiadomości:
    6 693
    Miejscowość:
    Nowy Sącz
    Local Time:
    14:25
    Oceny:
    +1 485 / 30 / -6
    Followers:
    25
    QNAP:
    TVS-x71
    Ethernet:
    1 GbE
    TVS-x71 1 GbE
    A dotyczy to serwera QNAP? :)
    Ustaw w profilu model serwera :D
     
  4. milwis
    Offline

    milwis Nowy użytkownik Noobie

    Dołączył:
    24 Sierpień 2017
    Wiadomości:
    7
    Local Time:
    14:25
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x69 Pro
    Ethernet:
    1 GbE
    TS-x69 Pro 1 GbE
    Tak. Poprostu mam 2 qnapy, na których stoi ftp pod tym samym zewnętrznym adresem ip :)