Help Magnet link rTorrent PRO nie działa

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
Czy ktoś zna rozwiązanie na niedziałające Magnet Links w rTorrent PRO ? Ostatnio przestały mi kompletnie działać ( po aktualizacji do najnowszej wersji ) a wcześniej raz działały a raz nie - generalnie po dodaniu w rTorrent PRO linku magnet stoi na pozyskiwaniu "meta" ( czyli np A845fnosfhof.meta ) zero seedów / 0 peerów z kolei jak dodam zwykły torrent to co prawda się dodaje ale jest również 0 seedów i 0 peerów - problem dotyczy głównie rarbg bo z innych stron większość działa niezależnie czy to jest zwykły torrent czy magnet link. ( dodam iż wszystko przechodzi przez QVPN ( OpenVPN ) - ale tu nie zmieniałem ustawień i było wcześniej - profilaktycznie załądowałem nowe profile od nowa ale nie pomogło ).
 

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
Nie wiem, podeslij przykładowe linki
Przykładowo do testu magnet:?xt=urn:btih:d0cf4df4e5900b252870281d86dbec0b7ec8adcb&dn=Road.Wars.2022.S01E01.720p.WEB.h264-BAE%5Brartv%5D&tr=http%3A%2F%2Ftracker.trackerfix.com%3A80%2Fannounce&tr=udp%3A%2F%2F9.rarbg.me%3A2750&tr=udp%3A%2F%2F9.rarbg.to%3A2930&tr=udp%3A%2F%2Ftracker.thinelephant.org%3A12760&tr=udp%3A%2F%2Ftracker.slowcheetah.org%3A14790
 

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,530
17
1,906
153
37
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
Wykonałem test, działa!

Link: https://youtu.be/a2iohH1btnE


Nawet zrestartowałem rtorrent-Pro aby zaktualizował IP Filter list:
1657267737191.png

Działa:
1657267938590.png
 
  • Like
Reactions: pigers

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,530
17
1,906
153
37
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
I. Upewnij się, że DHT jest włączone
II. Przekieruj port DHT oraz port rtorrent

-

1. Reset ustawien rtorrent-a
2. Jeśli nie pomoże odinstalować zainstalować ponownie
3. Reset ustawień sieciowych QNAP
 
  • Like
Reactions: candidate

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
I. Upewnij się, że DHT jest włączone
II. Przekieruj port DHT oraz port rtorrent

-

1. Reset ustawien rtorrent-a
2. Jeśli nie pomoże odinstalować zainstalować ponownie
3. Reset ustawień sieciowych QNAP
Ok dzięki dam znać czy coś pomoże chociaż resetu ustawień sieciowych qnap wolałbym uniknąć ale może chodzi o przekierowanie DHT bi na routerze miałem tylko port torrent przekierowany. Rozumiem ze przekierowanie robię na IP qnap a nie bramy domyślnej ( głównego routera ) ?
 

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,530
17
1,906
153
37
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
Na routerze robisz przekierowanie na IP QNAP port 42000->42000
DHT teoretycznie nie jest konieczny jeśli nic nie udostępniasz. Możesz skorzystać z UPnP i zobaczyć czy to przypadkiem nie rozwiąże Twojego problemu.
Jeśli nie chcesz korzystać z UPnP wbudowanego w Rtorrent-Pro, możesz przejść do myQNAPcloud w QNAP i tam w automatycznej konfiguracji routera dodać reguły dla rtorrent porty: 42000 i 6881.
 

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
Nie kumam już tego rTorrenta - samo zaczęło działać a nic jeszcze nie zdążyłem zmienić LOL.... No nic póki działa nie dotykam a jeśli znowu pojawi się problem to zastosuje się do powyższych wskazówek i dam znać.
 

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,530
17
1,906
153
37
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
Może router i przekierowania portów się zawiesiły? A może masz jakiś słabszy router i wykorzystałeś Max połączeń TCP?
 

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
Może router i przekierowania portów się zawiesiły? A może masz jakiś słabszy router i wykorzystałeś Max połączeń TCP?
Ciężko powiedzieć Router to Asus RT- AC87U - będę monitorował sytuacje ;)
 

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
Niestety problem szybko powrócił - znowu to samo . Jak tylko wyłącze VPN na Qnap wszystko śmiga , żadne porty nie są blokowane itp itd torrenty wszystkie śmigają . VPN mam od WindScribe ( Open VPN )jeśli to ma jakieś znaczenie
 

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
a WindScribe masz VPN'a ktory zezwala na torrenting?
Tak według WindScribe wszystkie ich serwery pozwalają na torrent z wyjątkiem kilku krajów . Ewentualnie inny sprawdzony VPN pod torrent polecasz ? Taki który dobrze współpracuje z rTorrernt ?
 

candidate

Entry Technician
Q Associate
Oct 5, 2017
75
3
8
52
QNAP
TS-x53A
Ethernet
1 GbE
Jeśli ktoś jest zainteresowany to mały update: - testowo zmieniłem VPN na SurfShark i tutaj nie ma żadnych problemów z linkami magnet czy znalezieniem seed/peer - niestety nie wiedzieć czemu QNAP po paru godzinach pracy rozłącza VPN i rTorrent wskakuje automatycznie standardowe IP dostawcy Internetu :/ - przy ręcznej próbie wznowienia podłączenia VPN w QVPN połączenie nie chce zaskoczyć pomaga jedynie całkowity restart QNAP - jakieś dziwne rzeczy się dzieją :-(. Odką∂ zaczałem używać VPN to nie mogę zmusić do poprawnej pracy QNAP i rTorrent - ZAWSZE prędzej czy później coś jest nie halo :p - Na 99 % stawiam na brak wiedzy z mojej stronie skoro u większości osób rTorrent śmiga elegancko ;D
 
  • Like
Reactions: Silas Mariusz