Udzielamy pomocy Ponowna konfiguracja po awarii płyty głównej

Dyskusja w 'Replikacja i poawaryjne działania odtworzeniowe' rozpoczęta przez użytkownika drQwerty, 19 Czerwiec 2017.

Ładowanie...
  1. drQwerty
    Offline

    drQwerty Passing Basics Beginner

    Dołączył:
    12 Listopad 2011
    Wiadomości:
    13
    Local Time:
    12:55
    Oceny:
    +3 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x51
    Synology:
    110j
    Ethernet:
    802.11n
    TS-x51 802.11n
    Cześć wszystkim,

    Był sobie QNAP TS-251 a na nim firmware 4.3.3, aktualizowany na bierząco. W nim dwa dyski WD Red 3TB w RAID1. W systemie było kilkunastu użytkowników, przynajmniej dwóch trzymało coś w swoich katalogach domowych. Był jeszcze wolumin iSCSI, ale to osobna sprawa.

    Pewnego majowego dnia, prawdopodobnie na skutek zaniku napięcia, system padł i powstał, wysyłając emaila o systemie plików wymagającym czyszczenia.
    Następnie padł po raz drugi i już nie wstał.
    Serwis wymienił w nim płytę główną i NAS wrócił do mnie. Raczej w stanie natywnym, czyli do ponownej konfiguracji.

    Moje pytanie zasadnicze, powiedzmy nr 0, brzmi: jak przywrócić NASa do działania najszybciej, ale przede wszystkim najpełniej jeśli chodzi o dane ze starego systemu?

    Pytanie 1: Czy ze starych dysków da się odtworzyć konfigurację starych ustawień? Chodzi przede wszystkim o użytkowników, ich hasła i zawartość katalogów domowych. Z resztą katalogów chyba nie powinno być problemów, prawda?

    Póki co przychodzi mi do głowy tylko taki tok postępowania:
    a) Do świeżego NASa wkładam jeden z dysków tworzących RAID1, jest on formatowany i na nim ustawiany jest nowy system.
    b) Wkładam drugi dysk, z niego kopiuję dane na dysk pierwszy.
    c) Tworzę konta użytkowników.
    d) Korzystając z uprawnień roota kopiuję katalogi domowe do katalogów domowych nowo utworzonego systemu.
    e) Proszę użytkowników o zmianę haseł.

    Pytanie 3: Czy krok d) jest wykonalny?
    Pytanie 4: Czy w tak przedstawionym toku postępowania coś się może stać z danymi tak, że będą utracone na obu dyskach?
    Pytanie 5: Czy bezpieczniejsze jest podłaczenie któregoś dysku do peceta z uruchomionym linuksem live i za jego pośrednictwem przerzucenie danych?

    Będę wdzięczny za pomoc.


    Wersja oprogramowania Firmware: w sumie nie wiem z czym NAS przyszedł, przypuszczam, że ostatni
    Model serwera: QNAP TS-251
     
  2. pigers
    Offline

    pigers GOD's left hand - careful - he don't care anymore. Administrator

    Dołączył:
    26 Lipiec 2013
    Wiadomości:
    5 508
    Miejscowość:
    Nysa
    Local Time:
    12:55
    Oceny:
    +1 009 / 28 / -12
    Followers:
    2
    QNAP:
    TS-x53
    Synology:
    huh ? I do not collect crap
    Ethernet:
    1 GbE
    TS-x53 1 GbE
    1. wsadzasz dyski, włączasz NAS i patrzysz czy masz wszystko co było ustawione
    2. pijesz piwo za dobrze wykonaną robotę.
    --- Połączono posty, 19 Czerwiec 2017, Data oryginalnego postu: 19 Czerwiec 2017 ---
    3. od biedy robisz update firmware bo pewnie serwis nie wgrał najnowszego
     
  3. drQwerty
    Offline

    drQwerty Passing Basics Beginner

    Dołączył:
    12 Listopad 2011
    Wiadomości:
    13
    Local Time:
    12:55
    Oceny:
    +3 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x51
    Synology:
    110j
    Ethernet:
    802.11n
    TS-x51 802.11n
    Ha!
    Wygląda na to, że rzeczywiście było to tak proste!
    Dzięki, @pigers@pigers , oszczędziłeś mi daremnego kombinowania z konfigurowaniem.

    Tak przy okazji: czy gdybym włożył tylk jeden dysk efekt byłby podobny?
    Odpowiadając samemu sobie: chyba powinno, dzięki czemu po awarii i utracie jednego dysku system dalej byłby operatywny.
     
  4. pigers
    Offline

    pigers GOD's left hand - careful - he don't care anymore. Administrator

    Dołączył:
    26 Lipiec 2013
    Wiadomości:
    5 508
    Miejscowość:
    Nysa
    Local Time:
    12:55
    Oceny:
    +1 009 / 28 / -12
    Followers:
    2
    QNAP:
    TS-x53
    Synology:
    huh ? I do not collect crap
    Ethernet:
    1 GbE
    TS-x53 1 GbE
    w końcu raid1 ;)
     

Poleć tę stronę