Problem z ipkg

Dyskusja w 'Oh'Linux? Software hacking' rozpoczęta przez użytkownika mimimi, 10 Styczeń 2010.

Ładowanie...
  1. mimimi
    Offline

    mimimi Passing Basics Beginner

    Dołączył:
    17 Styczeń 2009
    Wiadomości:
    29
    Local Time:
    12:15
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-509 Pro
    Ethernet:
    1 GbE
    TS-509 Pro 1 GbE
    Hej,

    Próbuję zainstalować SVN na TS509 wg schematu zamieszczonego na forum jednak mam jakiegoś kwasa z ipkg.

    Przy próbie wykonania komendy
    Kod (Text):
    1. ipkg install
    otrzymyję komunikat

    Kod (Text):
    1. [/] # ipkg
    2. -sh: /opt/bin/ipkg: cannot execute binary file
    podejrzałem więc w interfejsie webowym QNAPa gdzie jest zainstalowany ipkg. Wyszło mi że w /share/MD0_DATA/.qpkg/Optware. Wlazłem do tego katalogu i odpaliłem tam ipkg. Dostałem komunikat:

    Kod (Text):
    1. [/share/MD0_DATA/.qpkg/Optware/bin] # ipkg
    2. -sh: /opt/bin/ipkg: cannot execute binary file
    3. [/share/MD0_DATA/.qpkg/Optware/bin] #
    4.  
    ścieżki wyexportowane.

    O co chodzi?
     
  2. Silas Mariusz
    Offline

    Silas Mariusz SysOp Administrator

    Dołączył:
    5 Kwiecień 2008
    Wiadomości:
    6 012
    Miejscowość:
    Nowy Sącz
    Local Time:
    14:15
    Oceny:
    +1 337 / 30 / -5
    Followers:
    22
    QNAP:
    TVS-x71
    Ethernet:
    1 GbE
    TVS-x71 1 GbE
    a napewno zainstalowales Optware dla serii urzadzen x86 (Intel)
    przypadkiem nie na arm'y?
     
  3. mimimi
    Offline

    mimimi Passing Basics Beginner

    Dołączył:
    17 Styczeń 2009
    Wiadomości:
    29
    Local Time:
    12:15
    Oceny:
    +1 / 0 / -0
    Followers:
    0
    QNAP:
    TS-509 Pro
    Ethernet:
    1 GbE
    TS-509 Pro 1 GbE
    Tak było jak mówiłeś. Zainstalowałem ipkg nie dla Intela.

    Po instalacji właściwego, wszystko poszło jak z płatka. I postawiłem sobie svn-a

    Pozdro
     

Poleć tę stronę