Udzielamy pomocy TS-509 - próba reanimacji

Dyskusja w 'Oh'Linux? Software hacking' rozpoczęta przez użytkownika shamet, 10 Listopad 2016.

Ładowanie...
  1. shamet
    Offline

    shamet Nowy użytkownik Noobie

    Dołączył:
    20 Kwiecień 2015
    Wiadomości:
    3
    Local Time:
    18:50
    Oceny:
    +2 / 0 / -0
    Followers:
    0
    QNAP:
    TS-509 Pro
    Ethernet:
    100 Mbps
    TS-509 Pro 100 Mbps
    Witam,

    Sprawa jest taka. Mam leciwego TS-509Pro. Padły w nim karty sieciowe.
    Były podjęte próby naprawy płyty, ale spełzły na niczym. Raczej nie mam zamiaru już jej nigdzie wysyłać, bo każdy dodatkowy grosz wydany na reanimację tego "dziadka" jest bez sensu moim zdaniem.
    Nie jestem w stanie go używać na sofcie Qnapowym bo nie potrafię go zainicjalizować tylko na karcie wifi (odpalenie wifi wymaga działającego systemu, albo jakichś innych czarów z konsoli, których nie znam).
    Tu pytanie pierwsze. Czy jest jakiś sposób, żeby czystego nie zainicjalizowanego nasa na sofcie Qnap zmusić do użycia karty wifi i potem normalnie używać tylko po wifi?

    Próbowałem na nim zainstalować jakiegoś innego linuxa. Wybór padł na minta, bo go lubię.
    Problem jednak polega na tym, że dyski Sata nie są wykrywane przez bios ale dopiero po odpaleniu linuxa na przykład z pena usb i załadowaniu sterowników.
    Stąd też nie ma możliwości wystartowania systemu z dysku sata. Zainstalowałem minta na dysku sata a bootloadera na zapasowej kości flash dom.
    Jednak bootloader również nie widzi dysku w związku z czym nie jest w stanie wystartować systemu.

    Tu pytanie drugie:
    Czy da się jakoś zainstalować linuxa częściowo na kości dom, a częśćiowo na dysku sata ale tak, żeby jądro i sterowniki były startowane z kości dom a potem dopiero z dysku?

    Z góry dzięki za pomoc.

    Pozdrawiam
     
  2. pigers
    Online

    pigers GOD's left hand - careful - he don't care anymore. Administrator

    Dołączył:
    26 Lipiec 2013
    Wiadomości:
    5 462
    Miejscowość:
    Nysa
    Local Time:
    18:50
    Oceny:
    +1 007 / 28 / -12
    Followers:
    2
    QNAP:
    TS-x53
    Synology:
    huh ? I do not collect crap
    Ethernet:
    1 GbE
  3. shamet
    Offline

    shamet Nowy użytkownik Noobie

    Dołączył:
    20 Kwiecień 2015
    Wiadomości:
    3
    Local Time:
    18:50
    Oceny:
    +2 / 0 / -0
    Followers:
    0
    QNAP:
    TS-509 Pro
    Ethernet:
    100 Mbps
    TS-509 Pro 100 Mbps
    Heja. Nie jeszcze.
    Jakby się dało to spróbowałbym najpierw jakoś odpalić QTS'a po wifi i dopiero jak juz uznam na 100% że się nie da to spróbuję z debianem. Coś już czytałem na ten temat, ale trafiłem na opis, gdzie 509 nie był wymieniony na liście sprzętów wspieranych przez to "rozwiązanie".
    Inna rzecz, że debian mi tak se leży.
    Pewnie dało by się ten patent na potrzeby minta zaadaptować, ale jak pisałem wcześniej to już jak się okaże, że QTS nie ruszy.
     
  4. badziewiak
    Offline

    badziewiak Enterprise Admin... Q's Architect

    Dołączył:
    3 Marzec 2015
    Wiadomości:
    656
    Miejscowość:
    Gliwice
    Local Time:
    18:50
    Oceny:
    +142 / 9 / -1
    Followers:
    1
    QNAP:
    TVS-871
    Synology:
    nędza
    Ethernet:
    1 GbE
    TVS-871 1 GbE
    A czy nie da się podpiąć karty sieciowej RJ45->USB? Koszt ok. 50PLN, tylko nie mam pewności czy zadziała.
     
  5. shamet
    Offline

    shamet Nowy użytkownik Noobie

    Dołączył:
    20 Kwiecień 2015
    Wiadomości:
    3
    Local Time:
    18:50
    Oceny:
    +2 / 0 / -0
    Followers:
    0
    QNAP:
    TS-509 Pro
    Ethernet:
    100 Mbps
    TS-509 Pro 100 Mbps
    Myślałem o tym, ale nie ma takich adapteerów na liście kompatybilnego sprzętu, więc raczej nie zatrybi. W sumie to trochę nielogiczne byłoby gdyby ktoś chciał podłączać kartę sieciową na usb do sprzętu, który ma 2 wbudowane (przynajmniej działający) :)
    --- Połączono posty, 11 Listopad 2016, Data oryginalnego postu: 10 Listopad 2016 ---
    Pytanie drugie wycofuję. Rozwiązanie było dość proste. Wystarczyło przy instalacji partycję /boot i bootloader umieścić dysku flash/dom a resztę na Sata. System startuje bez problemu.

    Zostaje zatem pytanie pierwsze czyli jak podczas uruchomienia gołego QTS'a odpalić na nim kartę sieciową wifi żeby się móc z nim połączyć Qfinderem albo po prostu przez przeglądarkę i pojechać dalej z konfiguracją.
    Z góry dzięki za ewentualne pomysły.
     

Poleć tę stronę