Użycie karty audio USB jako wyjście dżwięku dla Debiana w LXC

mackowiakp

Passing Basics
Beginner
Jun 5, 2015
29
3
3
Gdynia
QNAP
TS-x53
Ethernet
1 GbE
Mam zainstalowanego w kontenerze LXC na QNAP, Debian Buster 18. Chciałbym używać w tym Debianie dźwięku, niezależnie od HDMI. HDMI wykorzystuję do podłączenia TV.
W tym celu podłączyłem do portu USB, moduł audio. No-name ale pracuje poprawnie z Linuxem na moim desktopie.
Po podłączeniu do NAS, zarówno sam NAS jak i Debian w kontenerze prawidłowo rozpoznają urządzenie:

root@Debian:~# cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0x81810000 irq 130
1 [Device ]: USB-Audio - USB Audio Device
GeneralPlus USB Audio Device at usb-0000:00:14.0-1, full speed

Jednak ani ALSA ani tym bardziej PulseAudio nie widzi tej karty:

root@Debian:~# aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
jack
JACK Audio Connection Kit
pulse
PulseAudio Sound Server

Z GUI Debiana korzystam bardzo rzadko. A jeżeli już to poprzez VNC. Jednak próba uruchomienia z GUI PulseAudio, kończy się zwisem aplikacji.
W ustawieniach kontenera mam ustawioną możliwość korzystania z tego urządzenia USB podłączonego do NAS przez kontener.

Co więc można zrobić aby możliwe było użycie USB audio przez kontener LXC z Debianem?


Wersja oprogramowania Firmware: 4.4.3.1421
Model serwera: QNAP TS-453A
 

Wrel

Nowy użytkownik
Noobie
Oct 21, 2020
1
0
1
QNAP
TS-653D
Ethernet
100 GbE
Mam zainstalowanego w kontenerze LXC na QNAP, Debian Buster 18. Chciałbym używać w tym Debianie dźwięku, niezależnie od HDMI. HDMI wykorzystuję do podłączenia TV.
W tym celu podłączyłem do portu USB, moduł audio. No-name ale pracuje poprawnie z Linuxem na moim desktopie.
Po podłączeniu do NAS, zarówno sam NAS jak i Debian w kontenerze prawidłowo rozpoznają urządzenie:



Jednak ani ALSA ani tym bardziej PulseAudio nie widzi tej karty:



Z GUI Debiana korzystam bardzo rzadko. A jeżeli już to poprzez VNC. Jednak próba uruchomienia z GUI PulseAudio, kończy się zwisem aplikacji.
W ustawieniach kontenera mam ustawioną możliwość korzystania z tego urządzenia USB podłączonego do NAS przez kontener.

Co więc można zrobić aby możliwe było użycie USB audio przez kontener LXC z Debianem?


Wersja oprogramowania Firmware: 4.4.3.1421
Model serwera: QNAP TS-453A

Mam pytanie czy udało się rozwiązać problem bo też nie mogę sobie poradzić z dźwiękiem z DACa USB.
Cisza w głośnikach, widzę że NAS prawidłowo rozpoznaje urządzenie:

$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xa1810000 irq 134
1 [II ]: USB-Audio - Music Streamer II+
www.hirestech.com 2013 REV 3.0 Music Streamer II+ at usb-0000:00:15.0-5, full s

Model: TS-653D

Mam też starszy HS-251 i tam wszystko śmiga OK.