Help Instalacja Mattermost na TS-464 przez Container Station

gf401-00

Nowy użytkownik
Noobie
May 9, 2024
3
0
1
33
QNAP
TS-x64
Ethernet
1 GbE
Witam,
posiadam QNAP TS-464eU z QTS 5.1.6.2722. Zainstalowałem Container Station i chcę zainstalować najnowszą wersję Mattemost. Korzystałem z tego poradnika Install Mattermost on QNAP NAS with Container Station - Brian Prom Blog , ale nie mogę zainstalować aplikacji. Udało mi się postawić Postgres-a utworzyć bazę ale nie wiem co jest w tym kodzie nie tak że nie mogę odpalić tej aplikacji. Posiada ktoś jakiś sprawdzony sposób na instalację i konfigurację?
 
Nikt nie wie co jest w tym kodzie nie tak że nie możesz odpalić bo nic nie pokazałeś.
 
version: "3"

services:
mattermost:
image: mattermost/mattermost-enterprise-edition:latest
restart: unless-stopped
user: 0:0
environment:
MM_FEATUREFLAGS_BoardsProduct: true
MM_NO_DOCKER: true
MM_SERVICESETTINGS_SITEURL: http://192.168.1.10:8065
MM_SQLSETTINGS_DATASOURCE: postgres://admin:qwerty@127.0.0.1:5432/mattermost?sslmode=disable&connect_timeout=10
PATH: /mattermost/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
volumes:
- /share/Container/mattermost/client/plugins:/mattermost/client/plugins
- /share/Container/mattermost/config:/mattermost/config
- /share/Container/mattermost/data:/mattermost/data
- /share/Container/mattermost/logs:/mattermost/logs
- /share/Container/mattermost/plugins:/mattermost/plugins
network_mode: host

serwer bazy danych 192.168.1.10 Postgres 14.6
Nazwa bazy danych MATTERMOST
Post automatically merged:

dane postgres

version: '3'
services:
postgres:
image: postgres:14.6
restart: unless-stopped
ports:
- 127.0.0.1:5432:5432
volumes:
- postgres_db:/var/lib/postgresql/data
environment:
- POSTGRES_USER=admin
- POSTGRES_PASSWORD=qwerty
phppgadmin:
image: qnapsystem/phppgadmin:7.13.0-1
restart: on-failure
ports:
- 7070:80
depends_on:
- postgres
environment:
- PHP_PG_ADMIN_SERVER_HOST=postgres
- PHP_PG_ADMIN_SERVER_PORT=5432

volumes:
postgres_db:
 
Jeżeli użyjesz formaterów kodu łatwiej będzie innym spróbować odtworzyć problem
Zrzut ekranu 2024-05-09 225735.png


Nie wiem czy z premedytacją ale jeżeli nie używasz tej bazy danych do innych rzeczy możesz to połączyć

YAML:
version: "3"

services:

  mattermost:
    # Mimo wszystko postarał bym się zdefiniować wersję zamiast używać ostatniej latest https://hub.docker.com/r/mattermost/mattermost-enterprise-edition/tags
    image: mattermost/mattermost-enterprise-edition:latest
    restart: unless-stopped
    user: 0:0
    environment:
      MM_FEATUREFLAGS_BoardsProduct: true
      MM_NO_DOCKER: true
      # Nie wiem czy to ci zadziała jestes pewien że pod tym adresem jest upubliczniane być może czy ten sam port nie sądze barakuje ci EXPOSE_PORT
      MM_SERVICESETTINGS_SITEURL: http://192.168.1.10:8065
     # Odwołaj się do serwisu po nazwie nie IP
      MM_SQLSETTINGS_DATASOURCE: postgres://admin:qwerty@postgres:5432/mattermost?sslmode=disable&connect_timeout=10
      PATH: /mattermost/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    volumes:
      - /share/Container/mattermost/client/plugins:/mattermost/client/plugins
      - /share/Container/mattermost/config:/mattermost/config
      - /share/Container/mattermost/data:/mattermost/data
      - /share/Container/mattermost/logs:/mattermost/logs
      - /share/Container/mattermost/plugins:/mattermost/plugins
    network_mode: host
    # Tego ci brakowało domyślnie on dostaje port ranodomowy > 3000
    ports:
      - 8065:8065
   # Powinno ci zagwarantować kolejność uruchamiania i link do hosta po nazwie nie trzeba po adresie ip
    depends_on:
      - postgres

  phppgadmin:
    image: qnapsystem/phppgadmin:7.13.0-1
    restart: on-failure
    ports:
      - 7070:80
    depends_on:
      - postgres
    environment:
      - PHP_PG_ADMIN_SERVER_HOST=postgres
      - PHP_PG_ADMIN_SERVER_PORT=5432

  postgres:
    image: postgres:14.6
    restart: unless-stopped
    volumes:
      - postgres_db:/var/lib/postgresql/data
   # Nie jest to bład ale przynajmniej wramach jednego docker-compose albo -K=wartość albo K:wartość
    environment:
      - POSTGRES_USER=admin
      - POSTGRES_PASSWORD=qwerty

  # Skoro tworzysz jeden volumen dlaczego nie robisz tego samego dla pozostałych choć ja bym pozostał przy rozwiązaniu z mattermost
  volumes:
    postgres_db:
 
Dziekuję. Próbuję tego kodu ale wyrzuca mi błąd przy weryfikacji kodu.
Dopiero jak usunę parametr Volumes pokazuje że kod jest ok ale aplikacja się nie uruchamia
blad.jpg
 
Nie wyobrażam sobie aby to odpalań na pałę, `volumes` dla postgresa i metoss powinieneś ustawić pod swoje preferencje/środowiskowe ustawienia.