Help TS-231P - Problem z uprawnieniami dostępu do folderów

Sebastian_krk

Nowy użytkownik
Noobie
May 27, 2024
5
0
1
35
QNAP
TS-x31P
Ethernet
1 GbE
Witam serdecznie kolegów.

Mam problem ze swoim QNAP, po aktualizacji sprzętu do wersji QTS 5.1.7.2770 dyski które miałem zmapowane w win 10 i win 11 przestały żądać hasła do otwarcia wskazanych folderów. Przed aktualizacją wszystko było ok. W prostej konfiguracji użytkownik jeden konkretny lub cała grupa dostawała dostęp do swojego folderu, zawartość dysku nie była widoczna w przeglądarce (dla gości).

Obecnie Każdy ma dostęp do całego dysku. Oraz z poziomu przeglądarki np chrome, po wpisaniu ścieżki adres_ip/nazwa_folderu mam podgląd tego co jest w środku bez logowania hasłem

Próbowałem zmieniać uprawnienia: Foldery udostępnione->Edytuj uprawnienia do folderu udostępnionego i w teorii jak wiadomo po wybraniu READ, R/W, DENY wybieramy opcję i ma działać.
Problem w tym że nadrzędną wydaje się grupa wszystkich użytkowników, czy też administratorów, jeżeli zaznaczę w grupie wszystkich użytkowników deny, dostępu z przeglądarki nie ma, oraz nie mogę się zalogować poprzez mapowanie dysku. Czy jest możliwość usunięcia grupy wszystkich użytkowników? Jaka kolwiek próba dodania reguły deny z grupą everyone powoduje zablokowanie dostępu. W jaki sposób poprawnie ustawić uprawnienia w nowej wersji?

Reasumując potrzebuje ograniczyć dostęp gościa, oraz właściwie przypisać dostęp do folderów dla użytkowników. Z góry dzięki za sugestie.

Pozdrawiam
Sebastian
 

Attachments

  • 1.jpg
    1.jpg
    102.3 KB · Views: 14
  • 2.jpg
    2.jpg
    105.1 KB · Views: 13
  • 3.jpg
    3.jpg
    91.9 KB · Views: 14
  • 4.jpg
    4.jpg
    90 KB · Views: 14
DENY jest nadrzędne i zawsze blokuje dostęp - nieważne skąd przychodzi (grupa/user). Co zresztą masz napisane na dole strony.

Nie ustawiaj żadnego prawa grupie everyone i powinno być dobrze.

a grupa everyone ma być.
 
  • Like
Reactions: Kong
Obecnie sytuacja wygląda tak:

- grupa administratorzy ustawiona na RW
- everyone pusta
- główne foldery względem użytkowników RW
- prawa dostępu dla gościa, dla każdego folderu - brak dostępu

- w karcie zaawansowane prawa dostępu, zaznaczona opcja włącz zaawansowane uprawnienia dostępu
- bez Windows ACL
- bez agregacji folderów

QNAP dalej udostępnia zasoby bez hasła
 
Obecnie sytuacja wygląda tak:

- grupa administratorzy ustawiona na RW
- everyone pusta
- główne foldery względem użytkowników RW
- prawa dostępu dla gościa, dla każdego folderu - brak dostępu

- w karcie zaawansowane prawa dostępu, zaznaczona opcja włącz zaawansowane uprawnienia dostępu
- bez Windows ACL
- bez agregacji folderów

QNAP dalej udostępnia zasoby bez hasła

Dodatkowo SMB i WebDAV wydają mi się w porządku. Czy coś jeszcze może mieć wpływ na udostępnianie?
 

Attachments

  • 1.png
    1.png
    133.7 KB · Views: 8
  • 2.jpg
    2.jpg
    164 KB · Views: 8
  • 3.jpg
    3.jpg
    142.7 KB · Views: 8
Problem dotyczy wszystkich komputerów w sieci. Hasła nie są zapisane. Może downgrade oprogramowania ?
 

Users search this thread by keywords

  1. ftp