Help Błąd połączenia do iSCSI :initiator reported error (11 - iSCSI PDU timed out)

Status
Not open for further replies.

irs11

Nowy użytkownik
Noobie
Feb 24, 2023
3
1
3
43
QNAP
TS-832PX
Ethernet
2.5 GbE
Witajcie!

Zakupiłem niedawno Qnap PX TS-832PX i usiłuję podłączyć się do niego po iSCSI z ubuntu 20.04.

Skonfigurowałem target i LUN:

Zrzut ekranu z 2023-02-24 13-04-52.png


Przy jego skanowaniu z initiatora wszystko jest OK:
root@c4e-backupsrv:/etc/iscsi# sudo iscsiadm -m discovery -t sendtargets -p 10.0.0.10
10.0.0.10:3260,1 iqn.2004-04.com.qnap:ts-832px:iscsi.test.7da889
oot@c4e-backupsrv:/etc/iscsi# sudo iscsiadm -m node -o show
# BEGIN RECORD 2.0-874
node.name = iqn.2004-04.com.qnap:ts-832px:iscsi.test.7da889
node.tpgt = 1
node.startup = manual
node.leading_login = No
iface.hwaddress = <empty>
iface.ipaddress = <empty>
iface.iscsi_ifacename = default
iface.net_ifacename = <empty>
iface.gateway = <empty>
iface.subnet_mask = <empty>
iface.transport_name = tcp
iface.initiatorname = <empty>
iface.state = <empty>
iface.vlan_id = 0
iface.vlan_priority = 0
iface.vlan_state = <empty>
iface.iface_num = 0
iface.mtu = 0
iface.port = 0
iface.bootproto = <empty>
iface.dhcp_alt_client_id_state = <empty>
iface.dhcp_alt_client_id = <empty>
iface.dhcp_dns = <empty>
iface.dhcp_learn_iqn = <empty>
iface.dhcp_req_vendor_id_state = <empty>
iface.dhcp_vendor_id_state = <empty>
iface.dhcp_vendor_id = <empty>
iface.dhcp_slp_da = <empty>
iface.fragmentation = <empty>
iface.gratuitous_arp = <empty>
iface.incoming_forwarding = <empty>
iface.tos_state = <empty>
iface.tos = 0
iface.ttl = 0
iface.delayed_ack = <empty>
iface.tcp_nagle = <empty>
iface.tcp_wsf_state = <empty>
iface.tcp_wsf = 0
iface.tcp_timer_scale = 0
iface.tcp_timestamp = <empty>
iface.redirect = <empty>
iface.def_task_mgmt_timeout = 0
iface.header_digest = <empty>
iface.data_digest = <empty>
iface.immediate_data = <empty>
iface.initial_r2t = <empty>
iface.data_seq_inorder = <empty>
iface.data_pdu_inorder = <empty>
iface.erl = 0
iface.max_receive_data_len = 0
iface.first_burst_len = 0
iface.max_outstanding_r2t = 0
iface.max_burst_len = 0
iface.chap_auth = <empty>
iface.bidi_chap = <empty>
iface.strict_login_compliance = <empty>
iface.discovery_auth = <empty>
iface.discovery_logout = <empty>
node.discovery_address = 10.0.0.10
node.discovery_port = 3260
node.discovery_type = send_targets
node.session.initial_cmdsn = 0
node.session.initial_login_retry_max = 8
node.session.xmit_thread_priority = -20
node.session.cmds_max = 128
node.session.queue_depth = 32
node.session.nr_sessions = 1
node.session.auth.authmethod = CHAP
node.session.auth.username = test
node.session.auth.password = ********
node.session.auth.username_in = <empty>
node.session.auth.password_in = <empty>
node.session.timeo.replacement_timeout = 120
node.session.err_timeo.abort_timeout = 15
node.session.err_timeo.lu_reset_timeout = 30
node.session.err_timeo.tgt_reset_timeout = 30
node.session.err_timeo.host_reset_timeout = 60
node.session.iscsi.FastAbort = Yes
node.session.iscsi.InitialR2T = No
node.session.iscsi.ImmediateData = Yes
node.session.iscsi.FirstBurstLength = 262144
node.session.iscsi.MaxBurstLength = 16776192
node.session.iscsi.DefaultTime2Retain = 0
node.session.iscsi.DefaultTime2Wait = 2
node.session.iscsi.MaxConnections = 1
node.session.iscsi.MaxOutstandingR2T = 1
node.session.iscsi.ERL = 0
node.session.scan = auto
node.conn[0].address = 10.0.0.10
node.conn[0].port = 3260
node.conn[0].startup = manual
node.conn[0].tcp.window_size = 524288
node.conn[0].tcp.type_of_service = 0
node.conn[0].timeo.logout_timeout = 15
node.conn[0].timeo.login_timeout = 15
node.conn[0].timeo.auth_timeout = 45
node.conn[0].timeo.noop_out_interval = 5
node.conn[0].timeo.noop_out_timeout = 5
node.conn[0].iscsi.MaxXmitDataSegmentLength = 0
node.conn[0].iscsi.MaxRecvDataSegmentLength = 262144
node.conn[0].iscsi.HeaderDigest = None
node.conn[0].iscsi.DataDigest = None
node.conn[0].iscsi.IFMarker = No
node.conn[0].iscsi.OFMarker = No
# END RECORD


Niestety nie mogę się do niego zalogować - dostaję błąd jak niżej:
root@c4e-backupsrv:/etc/iscsi# sudo iscsiadm -m node --login
Logging in to [iface: default, target: iqn.2004-04.com.qnap:ts-832px:iscsi.test.7da889, portal: 10.0.0.10,3260] (multiple)
iscsiadm: Could not login to [iface: default, target: iqn.2004-04.com.qnap:ts-832px:iscsi.test.7da889, portal: 10.0.0.10,3260].
iscsiadm: initiator reported error (11 - iSCSI PDU timed out)
iscsiadm: Could not log into all portals

Ponadto w logach initiatora w momencie próby logowania pojawiają się wpisy:
Feb 24 12:10:34 c4e-backupsrv sudo[111174]: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Feb 24 12:10:34 c4e-backupsrv kernel: scsi host2: iSCSI Initiator over TCP/IP
Feb 24 12:12:48 c4e-backupsrv sudo[111174]: pam_unix(sudo:session): session closed for user root
Feb 24 12:12:48 c4e-backupsrv iscsid[109333]: Connection7:0 to [target: iqn.2004-04.com.qnap:ts-832px:iscsi.test.7da889, portal: 10.0.0.10,3260] through [iface: default] is shutdown.
Feb 24 12:17:01 c4e-backupsrv CRON[111189]: pam_unix(cron:session): session opened for user root by (uid=0)
Feb 24 12:17:01 c4e-backupsrv CRON[111190]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Feb 24 12:17:01 c4e-backupsrv CRON[111189]: pam_unix(cron:session): session closed for user root
Feb 24 12:19:25 c4e-backupsrv sudo[111192]: root : TTY=pts/1 ; PWD=/etc/iscsi ; USER=root ; COMMAND=/usr/sbin/iscsiadm -m node --login
Feb 24 12:19:25 c4e-backupsrv sudo[111192]: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Feb 24 12:19:25 c4e-backupsrv kernel: scsi host2: iSCSI Initiator over TCP/IP
Feb 24 12:21:39 c4e-backupsrv sudo[111192]: pam_unix(sudo:session): session closed for user root

ACL jest ustawiona na Default Policy
Target oraz Initiator są w tej samej sieci LAN, nie ma żadnych firewalli po drodze

Konfiguracja initiatora:

root@c4e-backupsrv:/etc/iscsi# cat initiatorname.iscsi
## DO NOT EDIT OR REMOVE THIS FILE!
## If you remove this file, the iSCSI daemon will not start.
## If you change the InitiatorName, existing access control lists
## may reject this initiator. The InitiatorName must be unique
## for each iSCSI initiator. Do NOT duplicate iSCSI InitiatorNames.
InitiatorName=iqn.1993-08.org.debian:01:865f4c11d4f7
vi /etc/iscsi/iscsid.conf
# Wszystko na wartościach domyślnych za wyjątkiem:
# To enable CHAP authentication set node.session.auth.authmethod
# to CHAP. The default is None.
node.session.auth.authmethod = CHAP

# To set a CHAP username and password for initiator
# authentication by the target(s), uncomment the following lines:
node.session.auth.username = test
node.session.auth.password = bardzotajnehaslo1234567890

Próbowałem wielokrotnie usuwać konfigurację i robić ponownie discovery.
RFC mówi że błąd 11 - PDU timeout może wynikać z niezgodności pól związanych z logowaniem (o ile dobrze to rozumię)
Hasło i użytkownik sprawdzone sto razy i na pewno zgodne

Podpowie ktoś jak do zdebugować i poprawić?
Dzięki i pozdrawiam
Post automatically merged:

UPDATE:
Znalazłem też w sieci informację że ten błąd może się pojawić jeżeli QNAP jest podłączony do tej samej więcej niż jednym interfejsem sieciowym:
“iscsiadm” Discovery TimeOut With Two Or More Network Interfaces in CentOS/RHEL

Ale to nie mój przypadek - konfiguracja sieci na initiatorze:
root@c4e-backupsrv:/etc/iscsi# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether fa:16:3e:af:b0:87 brd ff:ff:ff:ff:ff:ff
inet 10.0.8.47/20 brd 10.0.15.255 scope global dynamic ens3
valid_lft 67517sec preferred_lft 67517sec
inet6 fe80::f816:3eff:feaf:b087/64 scope link
valid_lft forever preferred_lft forever

Konfiguracja sieci na Qnap-ie:
1677319855809.png
 

Attachments

  • Zrzut ekranu z 2023-02-24 13-03-54.png
    Zrzut ekranu z 2023-02-24 13-03-54.png
    40.9 KB · Views: 12
Temat rozwiązany :)
Faktycznie był potrzebny restart open-iscsi. Ja go robiłem ale nie w tym momencie co potrzeba.
Usunąłem wszystko, przeklikałem wg w/w instrukcji i działa
Dziekuję @pigers !
 
Status
Not open for further replies.

Users search this thread by keywords

  1. iscsi
  2. iscsi hasło