Help Dana spoza wolumenu

johns

Nowy użytkownik
Noobie
Sep 18, 2018
3
2
3
46
QNAP
null
Ethernet
100 Mbps
Cześć.
Problem dotyczy TS-128A z dyskiem 4TB. Pierwotnie był utworzony pojedynczy wolumen cienki na cały dysk.
Przed awarią na HDD znajdowało się mniej więcej 2,5 TB danych (trochę potrzebnych dokumentów, sporo unikatowych wideo i audio).
Po instalacji jakiejś apki (podejrzewam QApache) coś się zj… NAS przestał reagować więc musiałem przywrócić system do defaults.
Następnie utworzyłem nowy wolumen, też cienki, na wolną przestrzeń.
Obecnie wygląda to tak:

ai.imgur.com_h20M3RS.jpg_c4ca4238a0b923820dcc509a6f75849b.jpg

ai.imgur.com_b35ZaIG.jpg_c4ca4238a0b923820dcc509a6f75849b.jpg


Teraz mam zagadkę jak przywrócić dane z wcześniejszego wolumenu? Jest to w ogóle możliwe?
Część odzyskałem z Windowsa przez RStudio ale nadal przeżywam stan przedzawałowy(boo).

Wersja oprogramowania Firmware: 4.3.4 Build 20180830
Model serwera: QNAP TS-128A
 
Niestety przycisk Odzyskaj jest nieaktywny, tak samo Przywróć w zarządzaniu pulą pamięci.
Ech, zdaje się, że całkowicie sprawę spieprzyłem.
Z poziomu konsoli można coś poczarować?
 
Hej.
Nie do końca jeszcze w to wierzę ale udało się! Po kolejnych kilku godzinach ślęczenia w Google trafiłem na temat o znikających wolumenach.
Tam pojawiła się niniejsza komenda:
Code:
/etc/init.d/init_lvm.sh
Uwaga! Nie rozumiem jej znaczenia, ale w wątku pisało, że odnajduje wolumeny, co parę osób potwierdziło.
Byłem zdesperowany, więc trochę bezrefleksyjnie usunąłem nowy wolumen i wrzuciłem powyższe przez SSH.
Uruchomiło się sprawdzanie plików, które przywróciło pierwotny wolumen!
Wszystkie pliki znów mam dostępne w folderach współdzielonych!
UFFF!
Dzięki.
 

Users search this thread by keywords

  1. pula nieaktywny