Help HS-251 Zniknęły dane z serwera. Pomocy!

Szasza

Passing Basics
Beginner
Sep 1, 2015
16
4
3
QNAP
HS-251
Ethernet
null
HS-251 Zniknęły dane z serwera. Pomocy!

Serwer ustawiony do pracy w RAID1. Na serwerze mam katalogi (wolumeny):
- Oryginalne: Backup, Download, home, homes, Multimedia, Public, Recordings, Web.
- Stworzone przeze mnie: MDQ, MM
- Podłączyłem dysk zewnętrzny: USB1

Używam katalogów: MDQ i MM do przechowywania zdjęć, dysk USB1 do filmów, oraz Backup (oryginalny) do wszelkiego rodzaju przechowywania dokumentów.
Od pewnego czasu zaczęły się ataki na mój serwer. Jest wiele prób logowania się z różnych stron świata. Na szczęście bezskuteczne. Żeby zwiększyć bezpieczeństwo, gdzieś wyczytałem, że dobrym zwyczajem jest stworzenie innego użytkownika o uprawnieniach admina, a admina wyłączyć. Tak też zrobiłem.

Tu zaczęła się gehenna!
Po tym jak stworzyłem nowego użytkownika, nadaniu mu praw administratora i wyłączeniu konta administratora, zniknęły mi wszystkie pliki z USB1, oraz dostęp do katalogu Backup.

Dysk USB1 jest pusty. Z poziomu QTS i bezpośrednio z Windowsa ma całą wolną przestrzeń. Wcześniej był w połowie zajęty. Po kliknięciu na katalog Backup wyskakuje: Wiadomość systemowa – FILE/FOLDER NOT EXIST. W zasobach MDQ oraz MM wszystko jest dobrze.

Przywróciłem admina i nic, straciłem wszystkie dane z Backup i USB1. Wygląda to tak jakbym stracił do nich dostęp. Gdzieś wyczytałem, żeby z poziomu SSH stworzyć od nowa folder Backup i tak zrobiłem. Teraz błędu przy klikaniu nie ma ale poprzedniej zawartości też nie ma.
Zrobiłem kilka razy restart z poziomu QTS i to co się stało z katalogiem Backup, stało się teraz tak samo z katalogiem Recordings. W tym przypadku nie ma to dla mnie znaczenia, bo tam nie mam danych.

Jak odzyskać dostęp do danych, które miałem w katalogu Backup i na dysku USB1?

Dodam, że miałem tam kilkadziesiąt tys plików (archiwalne dokumenty, zbierane przez kilkanaście lat) w wielu folderach. Odzyskanie samych plików bez struktury katalogów jest mało przydatne. Dyski są szyfrowane z poziomu QTS.

Czytałem o R-Studio, ale na razie boję się cokolwiek ruszyć, może ktoś miał podobny problem i wie dokładnie jak go rozwiązać? Nie jestem biegły ani w tego typu programach ani w Linuksie.


Wersja oprogramowania Firmware: 4.2.0 Build 2016/01/30
Model serwera: QNAP HS-251
 
Po tym jak stworzyłem nowego użytkownika, nadaniu mu praw administratora i wyłączeniu konta administratora, zniknęły mi wszystkie pliki z USB1, oraz dostęp do katalogu Backup.
Strzał w kolano w przypadku QNAPa.

Przywróciłem admina i nic, straciłem wszystkie dane z Backup i USB1. Wygląda to tak jakbym stracił do nich dostęp.
Przywrócić udział sieciowy - nie tworzyć plików od nowa.

Jak odzyskać dostęp do danych, które miałem w katalogu Backup i na dysku USB1?
Dyski są szyfrowane z poziomu QTS.
Rób ticketa do QNAPa helpdesk.qnap.com - swoją drogą po co szyfrować dane skoro nie masz ich kopii ?
 
Czyli bardzo źle :-(
Do tego co pozostało dostęp mam normalny, ale nic nie ruszam, żeby czegoś nie nadpisać. Dyski mogę odszyfrować, ale zastanawiam się na jakim poziomie było szyfrowanie, czy to nie spowoduje całkowitej utraty tego co zniknęło. Na razie jeden dysk w ogóle wyjąłem, żeby w razie czego mieć kopię całości.
Uruchamiając dwa dyski w Raid1 sądziłem, że się zabezpieczam przed utratą danych, taki był cel, ale nie pomyślałem, że zabezpieczam się tylko przed uszkodzeniem dysku a nie przed programem zarządzającym. Kopie miałem w planach. Dyski zaszyfrowałem, bo mieszkam na parterze i zawsze może się zdarzyć jeszcze gorsza rzecz.

Słabo to wyszło.
Jak w kilka dni nikt z podobnym doświadczeniem nic nie napisze, będę pisał w takim razie do QNAPa.
 

Users search this thread by keywords

  1. utrata danych