Padła Samba

Dyskusja w 'Inne' rozpoczęta przez użytkownika midzi, 17 Październik 2009.

Ładowanie...
  1. midzi
    Offline

    midzi Nowy użytkownik Noobie

    Dołączył:
    12 Październik 2009
    Wiadomości:
    7
    Local Time:
    01:02
    Oceny:
    +0 / 0 / -0
    Followers:
    0
    Cześć,

    kompletnie nie wiem, co się stało. Serwer wczoraj pracował sobie bezproblemowo, dziś rano jeszcze też. Zostawiłem mu na screenie slimrata z listą plików, aż tu widzę, że:
    1: Zapomniał, jak się nazywa.
    2: Q-finder krzyczy, że serwer nie jest skonfigurowany.
    3: Nie działa możliwość korzystania z plików w otoczeniu sieciowym.
    Serwer nie jest dostępny, a po restarcie w logu pojawił się komunikat, że nie widzi domyślnuych folderów i że najlepiej byłoby zacząć całą zabawę od nowa, na co nie mam specjalnej ochoty, maszynka stoi zaledwie kilka dni, a tu takie hece. Oprócz tego ciągle w logu pojawia się następujący komunikat:
    2009-10-17
    15:08:22
    System
    127.0.0.1
    localhost
    Re-launch process [smbd].
    Co mogę zrobić w tej sytuacji? Oczywiście wiadomo, można wszystko wyczyścić i bawić się od nowa, ale może da się tego uniknąć? Może Samba ma gdzieś bardziej konkretne logi, podpowie ktoś?
     
  2. midzi
    Offline

    midzi Nowy użytkownik Noobie

    Dołączył:
    12 Październik 2009
    Wiadomości:
    7
    Local Time:
    01:02
    Oceny:
    +0 / 0 / -0
    Followers:
    0
    Odpowiadam sam sobie, wystarczy wklepać w konsoli:
    cp /etc/default_config/smb.conf /etc/config/
    Niestety, jeśli mamy potworzonych dużo udziałów, trzeba się sporo naklikać. Przy okazji, taka uwaga:
    Jestem niewidomym użytkownikiem komputerów i korzystam do pracy z maszyną ze specjalnego programu udźwiękawiającego, który odczytuje wszystko, co znajduje się na ekranie komputera. Jeśli ktoś z administracji tego forum ma kontakt z ludźmi odpowiedzialnymi za projektowanie kreatorów dodawania użytkowników czy udziałów sieciowych, bardzo bym był wdzięczny, gdyby skłonił ich do stosowania standardowych guzików dalej, wstecz i anuluj - takich kwiatków w interfejsie jest niewiele, ale jednak. Ostatnio na jednej z list dyskusyjnych niewidomych użytkowników komputerów pojawił się wątek odnośnie serwerów QNAP, ludzie nie są w stanie sobie poradzić z tak elementarną czynnością, jak dodanie użytkownika, ze względu na te przyciski. Mi się udało, ale niekażdy ma tyle samozaparcia. :)
     
  3. Silas Mariusz
    Offline

    Silas Mariusz SysOp Administrator

    Dołączył:
    5 Kwiecień 2008
    Wiadomości:
    6 441
    Miejscowość:
    Nowy Sącz
    Local Time:
    01:02
    Oceny:
    +1 450 / 30 / -6
    Followers:
    24
    QNAP:
    TVS-x71
    Ethernet:
    1 GbE
    TVS-x71 1 GbE
    Witam

    Dziekuje za odpowiedz i sugestie. Przekazuje sprawe natychmiastowo do technikow. Jesli cos uda mi sie zalatwic to zaraz sie odezwe.

    Pozdrawiam
     
  4. Silas Mariusz
    Offline

    Silas Mariusz SysOp Administrator

    Dołączył:
    5 Kwiecień 2008
    Wiadomości:
    6 441
    Miejscowość:
    Nowy Sącz
    Local Time:
    01:02
    Oceny:
    +1 450 / 30 / -6
    Followers:
    24
    QNAP:
    TVS-x71
    Ethernet:
    1 GbE
    TVS-x71 1 GbE
    z konsoli wpisz:
    # cp /etc/default_config/smb.conf /mnt/HDA_ROOT/.config

    1. Uszkodził się plik /usr/local/samba/var/locks/smbd.pid
    2. Nie da się usunąć pliku smbd.pid, więc trzeba zmienić nazwę katalogu locks na np: lok
    3. Utworzyć katalog locks i skopiować do niego zawartość katalogu lok, bez pliku smbd.pid

    Plik smbd.pid utworzy się automatycznie.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Odrzuć powiadomienie.