PAR2 - instalacja przez ipkg

Nicodem

Nicodem

Staff
Contributor
Aug 15, 2008
145
3
18
45
Warszawa
Zainstalowałem dzisiaj przez ipkg SABnzbd a wraz z nim par2cmdline. Niestety odpalenie par2 wywalało następujący błąd:
Code:
[/opt/etc/init.d] # par2verify
par2verify: /lib/libgcc_s.so.1: version `GCC_3.3' not found (required by /opt/lib/libstdc++.so.6)

wywnioskowałem że mam złą wersję GCC, sprawdziłem w ipkg - jest wersja 3.4. Zainstalowałem ją (BTW: - to trwało wieki! 100% zajętości procka, 3Mb wolnej pamięci), odpaliłem par2verify i... znów nic:

Code:
[/opt/etc/init.d] # par2verify
par2verify: relocation error: par2verify: symbol __aeabi_atexit, version GLIBC_2.4 not defined in file libc.so.6 with link time reference

Jakieś pomysły? :)
 
Silas Mariusz

Silas Mariusz

rm -rf /
Help us, GOD!
Apr 5, 2008
10,132
31
2,204
153
39
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
1) czemu nie instalowales SABnzbd+ z poziomu QPKG? przeciez jest gotowa paczka SABnzbd dostepna poprzez QPKG

2) optware i jego oprogramowanie jest skompilowane na gcc_2_3_6, kiedy system qnap'a jest skompilowany na gcc_2_3_4
a wiec do poprawnego dzialania aplikacji z optware, nalezy wejsc na srodowisko optware i dopiero z niego odpalac aplikacje
dla urzadzen jednodyskowych lub konfiguracji single disk:
Code:
# chroot /share/HDA_DATA/optware
dla konfiguracji RAID:
Code:
# chroot /share/MD0_DATA/optware
po przejsciu na srodowisko optware odpal aplikacje :D
 
Nicodem

Nicodem

Staff
Contributor
Aug 15, 2008
145
3
18
45
Warszawa
SiLAS said:
1) czemu nie instalowales SABnzbd+ z poziomu QPKG? przeciez jest gotowa paczka SABnzbd dostepna poprzez QPKG

Primo - nie było jej w liście paczek wyświetlającej się w panelu administracyjnym QNAPa. Dopiero potem znalazłem ją jako BETA.
Secundo - mam 209PRO II od wczoraj. Zakup był spowodowany głównie z 2 powodów - potrzeba posiadania macierzy RAID z ważnymi danymi i... chęć przypomnienia sobie linux'a. Takiego prawdziwego - tylko z konsolą, problemami z instalacją, kompilowaniem itp. Kiedyś byłem w tym całkiem całkiem, ale to prawie 10 lat temu i teraz staram się sobie przypominać co i jak. Instalacja i gmeranie przy okazji błędów - uczy.
SiLAS said:
2) optware i jego oprogramowanie jest skompilowane na gcc_2_3_6, kiedy system qnap'a jest skompilowany na gcc_2_3_4
a wiec do poprawnego dzialania aplikacji z optware, nalezy wejsc na srodowisko optware i dopiero z niego odpalac aplikacje
dla urzadzen jednodyskowych lub konfiguracji single disk:
Code:
# chroot /share/HDA_DATA/optware
dla konfiguracji RAID:
Code:
# chroot /share/MD0_DATA/optware
po przejsciu na srodowisko optware odpal aplikacje :D

Czyli wszystkie paczki zainstalowane pczez optware (ikpg) mogą wymagać chroot'a?