Projekt Pi-hole – blokowanie reklam, ale bez Pi-hole, za to w samym Mikrotiku

Discussion in 'Oh'Linux? Software hacking' started by Silas Mariusz, Feb 22, 2020.

Loading...
  1. pigers
    Online

    pigers [PowerUser] - nie wiem i nie znam się Administrator

    Joined:
    Jul 26, 2013
    Messages:
    9,341
    Local Time:
    1:33 PM
    Ratings:
    +1,381 / 36 / -15
    Followers:
    5
    QNAP:
    TS-453 PRO
    Ethernet:
    1 GbE
    TS-453 PRO 1 GbE
    na debcu jest ten sam błąd
    poprawienie shebang na basha,wypluwa coraz wiecej bledów :


    upload_2020-3-24_14-18-46.
    --- Połączono posty, Mar 24, 2020 at 2:19 PM, Data oryginalnego postu: Mar 24, 2020 at 2:18 PM ---
    aliasy sie nie wczytały u mnie :p
     
  2. MajkiIT
    Offline

    MajkiIT System Engineer Q Specialist

    Joined:
    Mar 2, 2020
    Messages:
    17
    Local Time:
    1:33 PM
    Ratings:
    +3 / 0 / -0
    Followers:
    0
    QNAP:
    TS-210
    Ethernet:
    802.11ad
    TS-210 802.11ad

    Dałem :D . Dzięki
    https://raw.githubusercontent.com/M...olish-mikrotik-filters/addHoleCertDomains.rsc
    --- Połączono posty, Mar 24, 2020 at 5:40 PM ---
    Dla potomnych ==> może kogoś zainteresuje Blokowanie domen z listy HoleCert na Mikrotik, Pihole - ...::: CertyficateIT :::...
     
  3. Silas Mariusz
    Online

    Silas Mariusz SysOp Administrator

    Joined:
    Apr 5, 2008
    Messages:
    7,812
    Local Time:
    1:33 PM
    Ratings:
    +1,669 / 34 / -7
    Followers:
    32
    QNAP:
    TS-x77
    Ethernet:
    1 GbE
    TS-x77 1 GbE
    Spoko ale zamien to na automat. Scheduler ktory robi fetch, remove starych i dodaje nowe :)
    Po za tym masz bugi...
    /ip dns static remove [/ip dns static find comment~”addHoleCertDomains”]
    Twój cudzysłów nie jest standardowy.
    Powinno być:
    /ip dns static remove [/ip dns static find comment~"addHoleCertDomains"]

    tak to widze finalnie...
    Code (Text):
    1. # Script which will download the drop list as a text file
    2. /system script add name="DownloadAddHoleCertDomains" source={
    3. /tool fetch url="https://raw.githubusercontent.com/MajkiIT/polish-ads-filter/master/polish-mikrotik-filters/addHoleCertDomains.rsc" mode=http;
    4. :log info "Downloaded addHoleCertDomains.rsc from MajkiIT";
    5. }
    6.  
    7. # Script which will Remove old addHoleCertDomains list and add new one
    8. /system script add name="ReplaceAddHoleCertDomains" source={
    9. /ip dns static remove [/ip dns static find comment~"addHoleCertDomains"]
    10. /import file-name=addHoleCertDomains.rsc;
    11. :log info "Removed old addHoleCertDomains records and imported new list";
    12. }
    13.  
    14. # Schedule the download and application of the addHoleCertDomains list
    15. /system scheduler add comment="Download AdsBlock list" interval=1d \
    16.   name="DownloadAddHoleCertDomainsList" on-event=DownloadAddHoleCertDomains \
    17.   start-date=jan/01/1970 start-time=08:15:39
    18. /system scheduler add comment="Apply AdsBlock List" interval=1d \
    19.   name="InstallAddHoleCertDomainsList" on-event=ReplaceAddHoleCertDomains \
    20.   start-date=jan/01/1970 start-time=08:20:39
    --- Połączono posty, Mar 24, 2020 at 5:59 PM, Data oryginalnego postu: Mar 24, 2020 at 5:57 PM ---
    Aaaa okay widze, robisz automat - sorry nie doczytalem
     
    • Zgadzam się! Zgadzam się! x 1
  4. Silas Mariusz
    Online

    Silas Mariusz SysOp Administrator

    Joined:
    Apr 5, 2008
    Messages:
    7,812
    Local Time:
    1:33 PM
    Ratings:
    +1,669 / 34 / -7
    Followers:
    32
    QNAP:
    TS-x77
    Ethernet:
    1 GbE
    TS-x77 1 GbE
  5. pigers
    Online

    pigers [PowerUser] - nie wiem i nie znam się Administrator

    Joined:
    Jul 26, 2013
    Messages:
    9,341
    Local Time:
    1:33 PM
    Ratings:
    +1,381 / 36 / -15
    Followers:
    5
    QNAP:
    TS-453 PRO
    Ethernet:
    1 GbE
    TS-453 PRO 1 GbE
    1 GB ramu T-T.. zazdrość

    upload_2020-3-25_11-36-26.

    a wgrałem tylko custome listy :/
     
  6. Silas Mariusz
    Online

    Silas Mariusz SysOp Administrator

    Joined:
    Apr 5, 2008
    Messages:
    7,812
    Local Time:
    1:33 PM
    Ratings:
    +1,669 / 34 / -7
    Followers:
    32
    QNAP:
    TS-x77
    Ethernet:
    1 GbE
  7. _Toem
    Online

    _Toem Entry Technician Q Associate

    Joined:
    Dec 7, 2010
    Messages:
    79
    Local Time:
    12:33 PM
    Ratings:
    +9 / 0 / -0
    Followers:
    0
    QNAP:
    TS-410
    Ethernet:
    null
    TS-410 null
    To może ktoś się pokusi i udostępni na zbudowanie list - tych najważniejszych wpisów - dla danach sprawdzonych modeli / dostępnej pamięci MT ?
     
  8. MajkiIT
    Offline

    MajkiIT System Engineer Q Specialist

    Joined:
    Mar 2, 2020
    Messages:
    17
    Local Time:
    1:33 PM
    Ratings:
    +3 / 0 / -0
    Followers:
    0
    QNAP:
    TS-210
    Ethernet:
    802.11ad
    TS-210 802.11ad
  9. pigers
    Online

    pigers [PowerUser] - nie wiem i nie znam się Administrator

    Joined:
    Jul 26, 2013
    Messages:
    9,341
    Local Time:
    1:33 PM
    Ratings:
    +1,381 / 36 / -15
    Followers:
    5
    QNAP:
    TS-453 PRO
    Ethernet:
    1 GbE
    TS-453 PRO 1 GbE
    rozwiń myśl
     
  10. _Toem
    Online

    _Toem Entry Technician Q Associate

    Joined:
    Dec 7, 2010
    Messages:
    79
    Local Time:
    12:33 PM
    Ratings:
    +9 / 0 / -0
    Followers:
    0
    QNAP:
    TS-410
    Ethernet:
    null
    TS-410 null
    Z forum widać że testuje się różne listy w różnych konfiguracjach - a wiadomo że nie każdy MT jet najnowszy czy najsilniejszy - starsze rozwiązania mają słabsze możliwości czy chociażby zasoby pamięci. teoretycznie gdyby listy nawet te największe były by wgrane na medium np karta a nie do pamięci była by większa szansa , ale to ruch ze strony samego MT pewnie by musiał być.

    Ja podglądam i korzystam również z waszych pomysłów ale jak wcześniej pisałem po zamuleniu testowego MT szukam rozwiązań typu najczęściej pojawiające się zapytanie. Dlatego wpiąłem w środowisko do psucia RB z pi-holem żeby wpisywać na listy do MT te zapytania które są na topie w sieci.
    Do tego skrypt który pociąga sobie z aktualnej [ręcznej] list wpisy i aplikuje do wszystkich MT.
     
  11. MajkiIT
    Offline

    MajkiIT System Engineer Q Specialist

    Joined:
    Mar 2, 2020
    Messages:
    17
    Local Time:
    1:33 PM
    Ratings:
    +3 / 0 / -0
    Followers:
    0
    QNAP:
    TS-210
    Ethernet:
    802.11ad
    TS-210 802.11ad
    Tutaj potrzebny jest RAM, bo my wpisujemy stałe wpisy do DNS na MT. Każdy jest indywidualny, ale można coś wysupłać co najczęściej występuje.
     
    • Zgadzam się! Zgadzam się! x 1
  12. pigers
    Online

    pigers [PowerUser] - nie wiem i nie znam się Administrator

    Joined:
    Jul 26, 2013
    Messages:
    9,341
    Local Time:
    1:33 PM
    Ratings:
    +1,381 / 36 / -15
    Followers:
    5
    QNAP:
    TS-453 PRO
    Ethernet:
    1 GbE
    TS-453 PRO 1 GbE
    Ma to wadę że lecą ci zapisy na flashu w MT :p
     
  13. _Toem
    Online

    _Toem Entry Technician Q Associate

    Joined:
    Dec 7, 2010
    Messages:
    79
    Local Time:
    12:33 PM
    Ratings:
    +9 / 0 / -0
    Followers:
    0
    QNAP:
    TS-410
    Ethernet:
    null
    TS-410 null
    W zasadzie masz rację ale ..."lecą ci zapisy na flashu w MT"
    Czym się różni zapisz z
    Code (Text):
    1.  /tool fetch url="https://raw.githubusercontent.com.../addHoleCertDomains.rsc" mode=http;
    od zapisu z lokalnego ftp-a? skoro scheduler
    Code (Text):
    1. interval=1d
    i tak co dziennie zapisuje !? zobacz przedstawiony skrypt do MT, choć u siebie mam 7dni chyba ze duże zmiany to z reki
     
  14. pigers
    Online

    pigers [PowerUser] - nie wiem i nie znam się Administrator

    Joined:
    Jul 26, 2013
    Messages:
    9,341
    Local Time:
    1:33 PM
    Ratings:
    +1,381 / 36 / -15
    Followers:
    5
    QNAP:
    TS-453 PRO
    Ethernet:
    1 GbE
    TS-453 PRO 1 GbE
  15. _Toem
    Online

    _Toem Entry Technician Q Associate

    Joined:
    Dec 7, 2010
    Messages:
    79
    Local Time:
    12:33 PM
    Ratings:
    +9 / 0 / -0
    Followers:
    0
    QNAP:
    TS-410
    Ethernet:
    null
    TS-410 null
    Słuszność jest Malinka się spełnia tam gdzie może a w innych przypadkach ? - wykorzystanie wyuczonej listy , wpis do MT ograniczy pazerność reklam i nie tylko