Help Problem z swap

zorzyk

Network Architect
Q's Professional
Nov 9, 2015
9
1
3
42
QNAP
TS-x53Be
Ethernet
1 GbE
Witam serdecznie. Pojawił mi się problem z swap.
Mianowicie chodzi o to że jest ale ma zerową pojemność i wykorzystanie.
Wygląda to tak
Code:
[~] # parted /dev/sda print
Model: WDC WD30EFRX-68EUZN0 (scsi)
Disk /dev/sda: 3001GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags
 1      20.5kB  543MB   543MB   ext3            primary
 2      543MB   1086MB  543MB   linux-swap(v1)  primary
 3      1086MB  3000GB  2999GB  ext4            primary
 4      3000GB  3001GB  510MB   ext3            primary

[~] # free
             total       used       free     shared    buffers     cached
Mem:        515428     451820      63608          0       4280      97668
-/+ buffers/cache:     349872     165556
Swap:            0          0          0

Jak to naprawić.
Pozdrawiam.

Model serwera: QNAP TS-212P
 
Cfdisk Screenshot_2016-10-10-17-30-02.png
W jaki sposób można sprawdzić czy wszystko co jest potrzebne do swap jest tam gdzie powinno być?
Fdisk wypisuje mi coś takiego
Code:
Disk /dev/mtdblock0: 0 MB, 524288 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock0 doesn't contain a valid partition table
Disk /dev/mtdblock1: 2 MB, 2097152 bytes                                     255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock1 doesn't contain a valid partition table

Disk /dev/mtdblock2: 9 MB, 9437184 bytes
255 heads, 63 sectors/track, 1 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock2 doesn't contain a valid partition table

Disk /dev/mtdblock3: 3 MB, 3145728 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock3 doesn't contain a valid partition table

Disk /dev/mtdblock4: 0 MB, 262144 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock4 doesn't contain a valid partition table

Disk /dev/mtdblock5: 1 MB, 1310720 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock5 doesn't contain a valid partition table
You must set cylinders.
You can do this from the extra functions menu.

Disk /dev/sda: 0 MB, 0 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1      267350  2147483647+  ee  EFI GPT
Partition 1 has different physical/logical beginnings (non-Linux?):
     phys=(0, 0, 1) logical=(0, 0, 2)
Partition 1 has different physical/logical endings:
     phys=(1023, 254, 63) logical=(267349, 89, 4)

Disk /dev/sda4: 469 MB, 469893120 bytes
2 heads, 4 sectors/track, 114720 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/sda4 doesn't contain a valid partition table

Disk /dev/md9: 542 MB, 542769152 bytes
2 heads, 4 sectors/track, 132512 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md9 doesn't contain a valid partition table
[~] #
W jaki sposób można sprawdzić czy wszystko jest ok ze swap?
Czy istnieje, czy są odpowiednie pliki?
Ponieważ pokazuje mi się że 0 bajtów pojemności i wogule jak by nie działa. Soft najnowszy. Ale czasami mi się plex i minidlna wyłącza.
Dziękuję za każdą podpowiedź jak to naprawić.