Rozwiązany Problem z TLS - kontroler domeny (LDAP, LDAPS)

Discussion in 'Windows Active Directory' started by Miszkur, Jun 17, 2021.

Loading...
  1. Miszkur
    Offline

    Miszkur Passing Basics Beginner

    Joined:
    Jun 14, 2021
    Messages:
    2
    Local Time:
    11:10 AM
    Ratings:
    +0 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x31
    Ethernet:
    100 Mbps
    TS-x31 100 Mbps
    Witam.

    Skonfigurowałem na dwóch QNAPach niezależne kontrolery domeny (kontrolery są w różnych sieciach). Jeden QNAP to TS-431 P3, a drugi TS-251. Konfigurację mają podobną (wydaje mi się, że nawet identyczną).
    Zmodyfikowałem w pliku smb.conf w TS-251 i po restarcie smb wygenerowały się certyfikaty i LDAPS był dostępny.
    W przypadku wykonania tego samego na TS-431 P3 ten parametr jest nadpisywany poprzez smb.sh. Po sprawdzeniu skryptu wygląda na celowe działania na QNAPach procesorem typu ARM. Przy zakomentowaniu tego fragmentu skryptu smb nie chce się uruchomić z LDAPSem (w ogóle usługa LDAPa nie jest uruchomiona) i certyfikaty się nie wygenerowały.
    Czy komuś z Was udało się uruchomić LDAPS na QNAPie z ARMem na pokładzie? Czy wtedy może jednak certyfikaty trzeba ręcznie dograć?

    Ewentualnie próbowałem wykorzystać protokół LDAP, natomiast bez użycia certyfikatu otrzymuję komunikat (ldapsearch):
    ldap_bind: Strong(er) authentication required
    additional info: BindSimple: Transport encryption required.

    Przy użyciu parametru -Z (StartTLS) w ldapsearch i włączeniu TLS otrzymuję komunikat
    ldap_start_tls: Connect error (-11)
    additional info: The TLS connection was non-properly terminated.

    Przy obydwu wariantach nie można się podłączyć do domeny przy użyciu ldapsearch. Modyfikowałem ldap.conf na systemie, gdzie uruchamiałem ldapsearch dodając parametr TLS_REQCERT never i z tego co widziałem to także na QNAPie jest ustawione, ale nic to nie zmieniło.
    Komunikat "The TLS connection was non-properly terminated." nie pojawia się jedynie, gdy uruchomię LDAPS, ale niestety mogę tylko na jednym QNAPie.
    Czy ktoś co trzeba ustawić na QNAPie lub komputerze by ldapsearch był w stanie się podłączyć do LDAP z TLSem albo może jak wyłączyć w najgorszej opcji Stronger authentication?

    Wersja oprogramowania Firmware: 4.5.3.1697
    Model serwera: QNAP TS-431 P3

    Wersja oprogramowania Firmware: 4.5.3.1697
    Model serwera: QNAP TS-251
     
  2. pigers
    Offline

    pigers "Debbie" - always ask Silas ! Administrator

    Joined:
    Jul 26, 2013
    Messages:
    11,923
    Local Time:
    11:10 AM
    Ratings:
    +1,881 / 42 / -24
    Followers:
    8
    QNAP:
    TS-653D
    Ethernet:
    1 GbE
    TS-653D 1 GbE
    Not supported.
     
    • Meh Meh x 1
  3. Miszkur
    Offline

    Miszkur Passing Basics Beginner

    Joined:
    Jun 14, 2021
    Messages:
    2
    Local Time:
    11:10 AM
    Ratings:
    +0 / 0 / -0
    Followers:
    0
    QNAP:
    TS-x31
    Ethernet:
    100 Mbps
    TS-x31 100 Mbps
    Tego trochę się spodziewałem. To w takim wypadku pozostaje LDAP. To teraz pozostaje drugi problem jak się zalogować i użyć ldapsearch przy problemie z certyfikatem.