Help Problem z uruchomieniem Jellyfin na Qnap TS-431KX

Bremshey

Nowy użytkownik
Noobie
Mar 1, 2021
1
0
1
35
QNAP
TS-x31
Ethernet
100 Mbps
Wersja oprogramowania Firmware: 4.5.2.1566 Build 20210202
Model serwera: QNAP TS-431KX
Witam wszystkich,

nie będę ukrywał że jestem laikiem jeśli chodzi o wszystko o czym będę pisał i proszę o wyrozumiałość.
Zaczynając od początku, zakupiłem Qnapa głównie z myślą o bezpiecznym przechowywaniu osobistych danych (zdjęcia, filmy),stwierdziłem także że dobrym pomysłem będzie zastąpienie PC który częściowo pełnił rolę domowego serwera multimediów. Na PC działał mi bez zarzutu Universal Media Serwer jednak postanowiłem się przesiąść na Qnapa. Wbudowane opcje tj. Plex (dokupiona licencja płatna) oraz Media Streaming add-on zostawiają wiele do życzenia, stwarzają mniejsze lub większe problemy - klatkowanie niektórych filmów, problem z odtwarzaniem dźwięku czy też obrazu.

Po przejrzeniu alternatyw trafiłem na Jellyfin który wiele osób uruchamia z ContainerStation
Version 2.2.14.1638
.
Niestety u mnie nie jest tak gładko, jak wspominałem jestem laikiem w tym temacie, po przekopaniu kilku tutoriali jedyne do czego dochodzę to fakt że teoretycznie Jellyfin się uruchamia (kontener jest uruchomiony), niestety nie mogę się zalogować do samego GUI przez http, prosiłbym o pomoc, informację czy jest coś co powinienem zrobić dodatkowo. Wszystkie ustawienia Qnapa są stockowe, jedynie co zrobiłem to rzecz niezbędna w moim przypadku, RAID 5 oraz przypisany stały adres IP w sieci domowej.
Poniżej plik YAML który z edytowałem do swoich parametrów
version: "3.5"
services:
jellyfin:
image: linuxserver/jellyfin
container_name: jellyfin
user: 0:0
network_mode: "host"
volumes:
- /Container/jellyfin/config:/config
- /Container/jellyfincache:/cache
- /Dane/Filmy:/media
restart: "unless-stopped"
ports:
- 8096:8096
- 8920:8920
environment:
- JELLYFIN_PublishedServerUrl=http://192.168.1.17

po uruchomieniu w konsoli kontenera mam takie wpisy
To support LSIO projects visit:
Donations - LinuxServer
-------------------------------------
GID/UID
-------------------------------------

User uid: 911
User gid: 911
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] 40-gid-video: executing...
[cont-init.d] 40-gid-video: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

i już tutaj wydaje mi się że coś wygląda nie tak, po próbie zalogowania na porcie :8096 dostaję tylko informację "Ta witryna jest nieosiągalna".

Bardzo prosiłbym o pomoc w rozwiązaniu problemu, na wszystkie pytania odpowiem jak będę potrafił najlepiej
 
- /Container/jellyfin/config:/config - ścieżka z danymi w QNAPie zaczyna się od /share/
network_mode: "host" - sieć host ale wtedy nie działa przekierowanie portów z -p
JELLYFIN_PublishedServerUrl=[URL='http://192.168.1.17']http://192.168.1.17 - paramter opc[/URL]jonalny, nie ustawiaj go

popraw ścieżki dostępu do plików , znajdź adres IP kontenera z jellyfin i wtedy sprawdzaj
 

Users search this thread by keywords

  1. container sieć
  2. 431KX
  3. jellyfin