Help QNAP TS-251A po recovery - nie uruchamia się QTS, czarny ekran, brak urządzenia w sieci.

cysieq

Nowy użytkownik
Noobie
Jan 30, 2021
3
1
3
31
QNAP
TS-x51
Ethernet
1 GbE
Cześć!

Od dłuższego czasu szukam rozwiązania problemu, jaki dotknął uruchamianie systemu na QNAP TS-251A. Nie byłem w jego posiadaniu, gdy był sprawny. Nie mam dysków, na których pracował.

;TLDR;
Po recovery firmware czarny obraz i brak urządzenia w sieci via Qnap Finder. Szukam kogoś ze sprawnym egzemplarzem, kto zrobi mi obraz swojego DOM i prześle go aby wykluczyć uszkodzony plik recovery.


Wszystkie próby uruchomienia wykonuję na podłączonym monitorze via HDMI + klawiatura bezprzewodowa z nadajnikiem. (Próbowałem również z tradycyjną klawiatrą i myszą po USB.)
Urządzenie uruchamia się poprawnie, tj. przechodzi POST, podczas którego wyświetlany jest obraz starting słychać pierwszy buzz, wyświetla się cyferka 0 w lewym górnym rogu i ponownie nakładka starting poprzedzona drugim beepem.
W zależności od tego, z której partycji bootuje system (primary bądź backup) finalnie wyświetlany jest czarny ekran gdzie sygnał wypluwany na monitor jest ciągły, bądź sygnał jest przerywany i nadal nic się nie wyświetla.

Co do tej pory sprawdziłem:
  1. Firmware recovery konkretnie tym obrazem. Wszystkie partycje są widoczne fdisk -l nie pokazuje nic niepokojącego.
    • Plik wgrywany zarówno przez polecenia cp jak i dd na DOM.
  2. Wgranie tego samego obrazu na pendrive. Wyłączenie w BIOS bootowania z DOM, i próba uruchomienia obrazu z pendrive (USB na froncie i tyle urządzenia). Efekt ten sam.
    • Dla pewności sprawdziłem, że bez pendrive system nie może znaleźć partycji rozruchowej.
    • Zauważyłem jedynie, że po usłyszeniu drugiego beepa dioda sygnalizująca pracę pendrive gaśnie bezpowrotnie, do ponownego uruchomienia.
    • Sprawdzałem również na innym pendrive.
  3. Zarówno w przypadku 1 jak i 2 QNAP finder nie znajduje urządzenia w sieci.

  4. Uruchomienie systemu na innej kości RAM (fabrycznie 2x 1GB Adata ADDS1600X1G11-BSSQ) 1x 4GB Hynix HMT451S6BFR8A-PB. - bez zmian

  5. Różne kable HDMI i monitory -bez zmian

  6. bootowanie WIN 10 z hiren's boot - wszystko śmiga. Temperatury ok. Stress test CPU na 20 minut to nie problem. Napięcia zdaje się też w normie.

  7. Backup całego DOM do pliku obrazu. Zamontowanie pierwszej partycji rozruchowej DOM w Clonezilli i próba odczytu i zapisu pliku na niej - bezbłędnie

  8. Uruchomienie z czystym dyskiem HDD w zatoce 1 lub 2 - bez zmian

  9. Uruchomienie bez Backplane - bez zmian

  10. Wymiana baterii BIOS (+ reset ustawień) - bez zmian

  11. Podłączenie się kablem konsolowym (co prawda do compellenta) przez przejściówkę RS232-USB uniteka. - Brak danych na COM podczas całego bootowania. (Przejściówka działa na codzień ze switchami.)

  12. Uruchamianie z podłączonym / odłączonym LAN int1 / int2 - bez zmian
    • z bliżej niejednorodną częstotliwością mryga pomarańczowa dioda z przodu jak i przy porcie ok. mrygnięcie na sekundę.

Pytanie - Czy na pokładzie jest posiadacz działającego TS-251A, albo obrazu całego dysku DOM innego niż ten podany na stronie QNAPa (F_TS-X51A_20160429-1.3.0_EFI.img)

To mój pierwszy kontakt z QNAPem. Zainteresowałem się bardzo możliwościami OS tego malucha, liczę że uda mi się z nimi zapoznać. :)


Wersja oprogramowania Firmware: n-a
Wersja oprogramowania BIOS: 5.11
BIOS compliancy: UEFI 2.4; PI 1.3
BIOS Project version: QX85AR10 x64
BIOS Build date and time: 05/03/2016 14:41:29
BIOS EC version: QX85ED07
Model płyty głównej: QX69 Rev 2.0
Model DOM: THGBMBG5D1KBAIT
Model serwera: QNAP TS-251A

Pozdrawiam brać.
 
Obecnie używam tego Qnapa.

Dzięki za odzew.
Jesteś w stanie zrobić mi iso swojego obrazu?
W razie czego pomogę / zrobię instrukcję co i jak nawet i tutaj żeby zostało dla potomnych. >> Czareq121[małpa]gmail[kropka]com

Jak nie wstanie zaadaptuje go na debiana / freenasa. :)
 
Obecnie używam tego Qnapa.

Dzięki za odzew.
Jesteś w stanie zrobić mi iso swojego obrazu?
W razie czego pomogę / zrobię instrukcję co i jak nawet i tutaj żeby zostało dla potomnych. >> Czareq121[małpa]gmail[kropka]com

Jak nie wstanie zaadaptuje go na debiana / freenasa. :)

Musisz mi opisać jak mam to zrobić. Niestety nie mam doświadczenia w operacjach na QNAPie.
 
Obecnie używam tego Qnapa.

Dzięki za odzew.
Jesteś w stanie zrobić mi iso swojego obrazu?
W razie czego pomogę / zrobię instrukcję co i jak nawet i tutaj żeby zostało dla potomnych. >> Czareq121[małpa]gmail[kropka]com

Jak nie wstanie zaadaptuje go na debiana / freenasa. :)

Musisz mi opisać jak mam to zrobić. Niestety nie mam doświadczenia w operacjach na QNAPie.


Zatem instrukcja:

Potrzebujemy klawiatury, monitora by połączyć go z QNAPem i dwóch dysków np. pendrive / karta SD.
W moim przypadku będzie to pendrive 8gb i karta SD 32 GB. Takie miałem pod ręką. W sumie łatwiej będzie później rozpoznać odpowiednie dyski, gdy będą miały różne pojemności. Ważne żeby jeden z nich (nazwijmy go "1") był w stanie pomieścić ISO Clonezilli (~200MB) a drugi (nazwijmy go "2") obraz dysku startowego (nazwijmy go "3") QNAPA (4 GB).


Jeden z tych dysków na pewno będziemy formatować, więc zabezpiecz proszę wszystkie istotne dane z obu urządzeń na inne.


Przygotowanie dysków

Pobierz proszę dwa pliki
  1. Rufus https://github.com/pbatard/rufus/releases/download/v3.4/rufus-3.4.exe
  2. ISO Clonezilli https://sourceforge.net/projects/cl...0/clonezilla-live-2.4.2-10-amd64.iso/download
  1. Podłącz 1 dysk do PC, na który pobrano Rufusa i Clonezille.
  2. Zweryfikuj czy jest sformatowany jako FAT32.
    Format_USB_FAT32.png


  3. Uruchom program Rufus.
  4. Wybierz dysk 1 z menu rozwijanego pod etykietą Device
  5. Wskaż przyciskiem SELECT wcześniej pobrany plik "clonezilla-live-2.4.2-10-amd64.iso".


    Make_Bootable_USB_with_Rufus34.png


    Uwaga. Teraz skasujesz wszystkie dane z dysku nr 1.
  6. Kliknij przycisk START by uruchomić wgrywanie obrazu na dysk nr 1. Po chwili operacja powinna zakończyć się sukcesem.
  7. Wyłącz Rufusa.
  8. Podłącz dysk 2 i upewnij się, że on również sformatowany jest jako FAT32.
    Jeśli nie jest. Zabezpiecz znajdujące się na nim dane i wykonaj szybkie formatowanie do FAT32.

Bootowanie Clonezilli z QNAPa.

  1. Wyłącz QNAPa
  2. Wyjmij dyski z zatok NASa oznaczając obie kieszenie, co potem umożliwi włożenie ich w identyczny sposób gdy skończysz tą instrukcję.
  3. Podłącz klawiaturę, monitor, dysk 1 oraz dysk 2.
  4. Uruchom QNAPa wciskając cały czas przycisk Delete na klawiaturze, aż do uruchomienia BIOS.
    Bios_0.jpg


  5. W zakładce Save and Exit[/I]. w BIOS pod etykietą Boot Override[/I] znajdują się bootowalne dyski.
    W moim przypadku dyskiem 1 będzie [I]UEFI: SMI USB DISK 1100, Partition 1
    . Najprawdopodobniej wszystko, co będzie miało człon UEFI powinno uruchomić Clonezille Live.
    ai.ibb.co_VCbcnSJ_Qna2.jpg


    [*]Dalej wybieramy jak poniżej

    Boot_menu_-_Clonezilla_Live.png


    Clonezilla_Live1.png

    Clonezilla_Live2.png

    Clonezilla_Live3.png


    Clonezilla_Live4.png




    [*]Następnie pojawi się linia komend. Wpisujemy polecenia:
    • sudo su
    • fdisk -l lub fdisk -l | less w zależności od tego czy Twój monitor wyświetli cały output. (HINT: z edytora wychodzimy wpisując z klawiatury :w ;)
      W moim przypadku dyskiem 1 jest /dev/sda,
      ai.ibb.co_4fXcV7j_Qna4.jpg


      dyskiem 2 /dev/mmcblk0
      ai.ibb.co_N6gFzsX_Qna4.jpg


      a dyskiem 3 /dev/mmcblk1
      ai.ibb.co_smd3qZ2_Qna3.jpg
    [*]Kolejnym krokiem jest zamontowanie dysku 2, by móc skopiować na niego plik z obrazem. Tworzymy katalog, w którym zamontujemy dysk 2:
    mkdir -p /mnt/dysk2


    [*]Montujemy partycję /dev/mmcblk0p1 w utworzonym wcześniej katalogu.
    mount -t vfat /dev/mmcblk0p1 /mnt/dysk2


    [*]Przechodzimy do utworzonego katalogu.
    cd /mnt/dysk2


    [*]Wykonujemy operację utworzenia i kopiowania obrazu dysku 3 do pliku.
    dd if=/dev/mmcblk1 of=/mnt/dysk2/ObrazDysku3.iso
    Operacja potrwa kilka minut w zależności od prędkości pendrive.
    ai.ibb.co_MsdSHST_Qna5.jpg


Potem już tylko pozostaje przesłanie pliku. Jak już bedziesz go miał wystawię share.

Jak będzie problem z wykonaniem powyższego, to możemy jeszcze użyć samej clonezilli do tego. Oczywiście pomyślałem o tym jak już wszystko napisałem. :D

Pozdrawiam i dzięki z góry za pomoc.
 
Instrukcja wydaje się napisana dość dokładnie. Postaram się zrobić to w niedzielę.
Pliki zrobione i wysłane. Mam nadzieję że pomogą.
 

Users search this thread by keywords

  1. ts-251a
  2. ts-251a bios
  3. qx85ar10
  4. qnap nie uruchamia się
  5. 251a problem
  6. finder nie znajduje
  7. Bios
  8. po hdmi starting