Solved Serwer DLNA i foldery multimediów

Status
Not open for further replies.

christos

Nowy użytkownik
Noobie
Jan 24, 2022
3
1
3
QNAP
HS-210
Ethernet
1 GbE
Chciałem na moim urządzeniu (HS-210) uruchomić serwer DLNA. Mam jednak problem z dodaniem folderów mutimediów. Wchodząc do Panelu sterowania -> Uprawnienia -> Foldery współdzielone zaznaczam na wybranych folderach checkbox folder multimediów. Po zatwierdzeniu i kliknięciu Edytuj, checkbox nie jest zaznaczony. Nie ważne czy robię to dla folderów domyślnych (np. Multimedia) czy też dla folderów dodanych przeze mnie. Podobnie w Aplikacje -> Zarządzanie multimediami -> Folder multimediów. Próbuję dodać foldery dla zdjęć, muzyki czy plików video - bezskutecznie. Po kliknięciu Zastosuj bądź Zastosuj wszystkie, foldery znikają z listy. Szukałem trochę w sieci na ten temat - zdaje się, że to dość powszechna przypadłość. Wsparcie QNAP poinformowało mnie, że nie wspiera już tego oprogramowania. Zakładam, że jest to jakiś błąd GUI webowego i uda się problem rozwiązać po SSH. NIestety nie wiem gdzie szukać. Może ktoś z was spotkał się z takim problemem.
Pozdrawiam
 
Solution
producent nie wspiera - więc my umywamy ręce.
Jest takie powiedzenie: Jeśli czegoś nie da się zrobić - trzeba zawołać tego, który nie wie, że się nie da. Przyjdzie i zrobi. Jak pisałem - jestem dociekliwy i rozwiązałem ten jakże powszechny problem ze znikającymi folderami multimediów w QNAP'ach. Poniżej rozwiązanie.
Z jakiegoś powodu link do folderu (w moim przypadku) /share/MD0_DATA/.qpkg/medialibrary/ jest rozsiany w różnych miejscach. Przy czym dowiązania symboliczne nie prowadzą do w/w folderu lecz prowadzą do kolejnych dowiązań. w moim przypadku było to:
/usr/local/medialibrary -> /mnt/ext/opt/medialibrary -> /share/MD1_DATA/.qpkg/medialibrary/
Finalnie przez błędne dowiązanie posypał się cały powyższy...

pigers

Long live Pr0xM0x
Administrator
Jul 26, 2013
13,312
2,205
230
www.buymeacoffee.com
QNAP
QuTScloud
Ethernet
100 GbE
  • ·
  • QuTScloud
  • ·
  • 100 GbE
  • ·
  • Ten którego QNAP jeszcze nie ma ! Najnowszy na Debianie !
Zapomnieć o DLNA , wałkowane na forum , wiecznie same problemy, zero pożytku.
 

christos

Nowy użytkownik
Noobie
Jan 24, 2022
3
1
3
QNAP
HS-210
Ethernet
1 GbE
Zapomnieć o DLNA , wałkowane na forum , wiecznie same problemy, zero pożytku.
Zapewne tak się to skończy. Teraz to już bardziej wrodzona dociekliwość. Zakładam, że informacja o folderach multimediów powinna znaleźć się w jakimś pliku. Udało mi się trafić na /mnt/HDA_ROOT/.config/medialibrary.conf Być może ewentualna struktura folderów multimediów również jest tam zapisywana. Nie wiem niestety w jaki sposób i w jakich blokach. A może to zupełnie inny plik...
 

prozak64

Entry Technician
Q Associate
Nov 6, 2016
98
5
8
QNAP
TS-x53A
Ethernet
10 GbE
Najpierw trzeba doinstalować i poustawiać Media Streaming Add-on
 

christos

Nowy użytkownik
Noobie
Jan 24, 2022
3
1
3
QNAP
HS-210
Ethernet
1 GbE
producent nie wspiera - więc my umywamy ręce.
Jest takie powiedzenie: Jeśli czegoś nie da się zrobić - trzeba zawołać tego, który nie wie, że się nie da. Przyjdzie i zrobi. Jak pisałem - jestem dociekliwy i rozwiązałem ten jakże powszechny problem ze znikającymi folderami multimediów w QNAP'ach. Poniżej rozwiązanie.
Z jakiegoś powodu link do folderu (w moim przypadku) /share/MD0_DATA/.qpkg/medialibrary/ jest rozsiany w różnych miejscach. Przy czym dowiązania symboliczne nie prowadzą do w/w folderu lecz prowadzą do kolejnych dowiązań. w moim przypadku było to:
/usr/local/medialibrary -> /mnt/ext/opt/medialibrary -> /share/MD1_DATA/.qpkg/medialibrary/
Finalnie przez błędne dowiązanie posypał się cały powyższy łańcuszek. Wystarczyło wywalić błędny link, stworzyć prawidłowe dowiązanie i stał się cud. Działa.
Mam nadzieję, że komuś to się przyda.
 
Solution
Status
Not open for further replies.