Help Teoretyczne przeniesienie systemu z HDD na SSD - jak wykonać poprawnie, by coś nie zepsuć?

Marvin27

Entry Technician
Q Associate
Mar 1, 2020
47
4
8
34
Wojnicz
QNAP
TS-x73
Ethernet
2.5 GbE
Witam.
Posiadam QNAP QTS-TS-873 8GB, a na nim:
RAID 1 - 2x SSD 500GB SATA - używane obecnie jako warstwa ultraszybka z Qtier
RAID 5 - 4x HDD 8TB SATA - według załączonego screena jako system i magazyn danych z właczona funkcją Qtier. Oczywiście na WOLUMIN_1 są instalowane też aplikacje.
RAID 10 - 4x HDD 2TB SATA - dyski po starym RAID5 z komputera stacjonarnego, bez Qtier i jakichkolwiek aplikacji
przestrzeń dyskowa.png
Pula pamięci 1.png


Stwierdziłem jednak, że nie wiele mi daje ten Qtier z przyspieszeniem całego NAS-a. Na początku korzystania z QNAP stosowałem się do poradników i zwiększonego bezpieczeństwa przed utratą danych i dlatego skorzystałem z Qtier.

Reasumując chciałbym odłączyć dyski SSD od puli pamieć 1, a następnie zainstalować od nowa system QNAP-a na tych SSD oczywiście w konfiguracji RAID1, jakby miał mi się wysypać jakiś dysk SSD.

Moje obawy odnośnie do takiej operacji:
1. Czy jak uda mi się zainstalować system na dyskach SSD bez problemów, to czy bez problemów zainicjowania macierzy RAID dysków HDD?
2. Czy po włożeniu dysków HDD RAID 5, nie będzie konfliktu starego systemu z nowym ?


W jakich krokach powinienem wykonać tę operację?
I. Usunąć warstwę ultraszybką ? Akademia QNAP S01E02 - Pula pamięci i Qtier
qnap krok 1.png
II. Wyłączyć NAS-a i wyjąć dyski HDD.
III. Załączyć urządzenie i zainstalować / zainicjowanie od nowa systemu. <-- czy wcześniej przygotować specjalnie jakoś dyski SSD ?
IV. Wyłączyć urządzenie, włożyć 4 dyski RAID 5, włączyć NAS i czekać, aż system sam wykryje grupę RAID ?
V. To samo co wyżej dla RAID 10

Wiem, że może wyglądać to trochę chaotycznie, dlatego proszę o poradę odnośnie do moich obaw i kroków, jakie muszę wykonać.

Zastanawiałem się też nad dyskami SSD NVMe i na nim postawić system, ale cena adaptera PCI-E, jakoś mnie odrzuca. Chyba że jest możliwość zakupu tańszych używanych kart ?
 
Wiec niestety tak, to co jest skonfigurowane z Qtier musisz zbackupować. Nie ma mozliwosci tego odlaczenia.
Nastepnie uruchamiasz system na samych dyskach SSD lub je formatujesz w PC i inicjujesz instalacje.
Po zainstalowaniu systemu wkladasz dyski RAID 10 - 4x HDD 2TB SATA bez Qtiera i odzyskujesz je z panelu za pomocą funkcji recovery.
 
Wiec niestety tak, to co jest skonfigurowane z Qtier musisz zbackupować. Nie ma mozliwosci tego odlaczenia.
Dyski SSD odłączę, jak kreator usuwania warstwy ultraszybkiej przeniesie wszystkie dane z SSD na HDD z tej samej puli pamięci 1 ? Wtedy będzie to zwykły RAID 5 na HDD?
Nastepnie uruchamiasz system na samych dyskach SSD lub je formatujesz w PC i inicjujesz instalacje.
Lepiej wcześniej sformatować dyski SSD ? Przez SSH w QNAP też powinno się dać ?
 
Chyba zapomniałem o jeszcze jednym ważnym pytaniu:
Czy jak już będę z QTS na SSD oraz system wykryje mi dyski HDD jako RAID, to co się stanie z dostępem do zapisanych danych? Chodzi o "starych" użytkowników. Czy tu będzie jakiś problem ? Trzeba tworzyć ponownie tych samych klientów by był dostęp ?
 
Cześć.
Już przygotowuje się do wykonania przesiadki systemu QNAP-a, ale dalej mam dwie wątpliwości:
1. Czy po włożeniu dysków HDD RAID 5 (stary system), nie będzie konfliktu starego systemu z nowym ? Tzn - czy uruchomi się jako pierwszy nowy system z dysków SSD, czy stary system z HDD ?
2. Czy wkładać dyski HDD na hotplug, czy na wyłączonym urządzeniu ? Co bezpieczniejsze ? Czy QNAP obsługuje hotplug ?
 
1. Czy po włożeniu dysków HDD RAID 5 (stary system), nie będzie konfliktu starego systemu z nowym ? Tzn - czy uruchomi się jako pierwszy nowy system z dysków SSD, czy stary system z HDD ?
Przekonasz się o tym organoleptycznie.

2. Czy wkładać dyski HDD na hotplug, czy na wyłączonym urządzeniu ?
qnap ma hotpluga (no chyba że obudowa na to nie pozwala .. bądź jest to biedny armel) , zdecydowanie wciskaj dyski na gorąco - tak jak @Silas Mariusz pisał
Po zainstalowaniu systemu wkladasz dyski RAID 10 - 4x HDD 2TB SATA bez Qtiera i odzyskujesz je z panelu za pomocą funkcji recovery.
 
qnap ma hotpluga (no chyba że obudowa na to nie pozwala .. bądź jest to biedny armel) , zdecydowanie wciskaj dyski na gorąco - tak jak @Silas Mariusz pisał
W takim wypadku nie muszę się martwić pierwszym punktem.
Przekonasz się o tym organoleptycznie.
OK, więc idę na żywioł. Trzymać kciuki by się coś nie posypało (macierz) :)
 
Chyba zapomniałem o jeszcze jednym ważnym pytaniu:
Czy jak już będę z QTS na SSD oraz system wykryje mi dyski HDD jako RAID, to co się stanie z dostępem do zapisanych danych? Chodzi o "starych" użytkowników. Czy tu będzie jakiś problem ? Trzeba tworzyć ponownie tych samych klientów by był dostęp ?

Jeśli używasz zaawansowanych uprawnień to zrób eksport użytkowników i ich później zaimportuj.
Jeśli nie używasz to uprawnienia są per udział sieciowy. Musisz je na nowo przeklinać.
 
Aktualizacja — praktycznie wszystko się udało, jak zaproponowaliście wyżej w postach.
Wyryło obydwa macierze RAID, a QTS działa od teraz na dyskach SSD.
Więc dziękuje Panowie za pomoc.

Ale nie ma róży bez kolców — tak więc wywala mi błąd:
Błąd 2023-08-06 12:21:56 --- --- localhost --- Storage & Snapshots Storage Pool [Storage & Snapshots] Storage pool 288 is full. Unable to write data or create new snapshots. Delete some snapshots, free up space, or expand the pool.

oraz dioda STATUS jest na czerwono.
Post automatically merged:

Nie wiem, czy usuniecie WOLUMIN_1 (stary system) nie było błędem — teraz nie mogę znaleźć tego 1TB w puli pamięci RAID5.
 
W logach:
Informacje 2023-08-06 11:14:27 --- --- Web Desktop Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/115.0.0.0 Safari/537.36 Storage & Snapshots Volume [Storage & Snapshots] Started removing volume "WOLUMIN_1". Storage pool: 2.
Informacje 2023-08-06 11:15:35 --- --- Web Desktop Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/115.0.0.0 Safari/537.36 Storage & Snapshots Volume [Storage & Snapshots] Finished removing volume "WOLUMIN_1".

Więc wygląda OK.
 
Zgłosiłem ten problem przez Helpdesk i proszą o włączenie zdalnego wsparcia.
 

Users search this thread by keywords

  1. Przeniesienie systemu
  2. system na raid
  3. 453a
  4. qtier
  5. System na ssd
  6. przeniesienie systemu na ssd
  7. przeniesienie systemu na nvme
  8. ssd sata
  9. system na nvme
  10. aktualizacja
  11. nvme
  12. migracja na ssd
  13. dyski NVME na system
  14. przeniesienie systemu qm2
  15. system na m2
  16. dysk sata m2
  17. uprawnienia
  18. konfiguracja TS 464
  19. hotplug
  20. ssd na system
  21. migracja
  22. system przeniesienie
  23. dysk na system i aplikacje
  24. jak usunąć grupę raid
  25. recovery
  26. przeniesienie dysków
  27. Ssd
  28. system na qm2
  29. m.2 raid 0