TS-209 Pro/Std Official FW (Version 2.1.1 Beta Build 1024)

Silas Mariusz

Silas Mariusz

SysOp
Administrator
Apr 5, 2008
9,635
23
1,985
153
38
www.devspark.pl
QNAP
TS-x77
Ethernet
1 GbE
Guys,

Cumulative bugfixes for Octorber. (Note that items in red are specific to build 1024)


===========
[What's new?]
- Supports 1.5TB hard disks now
- Supports MAC Bonjour service
- Multimedia Station now supports Coolirs (Formerly PicLens)


[Enhancement]
- Added option to delete the files/directories when deleting the share.
- Upgrade Twonkymedia to 4.4.9
- Upgrade rsync from v2.6.6 to v3.0.4
- Upload/Install QPKG can now be done via QPKG web page (Was using the 'System Update' page)

- DDNS update function enhancement (Time interval settings added)
- Disable SMART test on Seagate hard drive with firmware version AN05.
- Network recycled bin now only supports file deletion via SAMBA & AFP (Spec. changed)
- Download Station UI component updated to adapt to IE7, IE8, Firefox 3 & Opera
- Download station now supports direct download from Rapidshare or through QRapid
- TS-x09 will now generate its unique FAQ SSH key files when FAQ SSH remote access is enabled at the first time.
- Adding a 'PRO II' string on the bottom of the administration page for identifying TS-109/209 Pro-II models
- Pressing and holding the reset button for 10 seconds will now restore to the default configuration settings.

[Major Bug Fixed]
- Synchronization deletes the existing files on the destination before taking place
- Hide network share does not work if the path was specified manually
- Rsyncd fails to restart after enabling the disk write-cache
- Solved IP address octets can't be configured to '255'
- Remote Replication fails while the destination NAS HDD goes into standby
- SMART Test schedule stops working after clicking on 'Reset' in 'Backup/ Restore/ Reset Settings' and reboots NAS
- Fixed incorrect link the 'FTP' button in Web File Manager
- MySQL & Apache stop running after RAID expansion finished.

- Fixed Surveillance station playback page not working
- NAS still shuts down when power cut on the UPS even though power recovers right after
- Web UI - Multimedia Station directory tree modified to adapt to IE7 and Firefox
- Incorrect default path for FAQ SSH (/usr/local/bin/FAQ SSH instead of /usr/local/bin/FAQ SSH) causing errors in SCP.
- Garbage characters are displayed in telnet
- Using wget (-q) generates garbage files (when installing softwares using 'ipkg install')
- UPS support broken with 'genpowered' process re-launched
- Errors on renaming a share folder name
- Back up to external eSATA drive fails

[Known Issues]
1.5TB hard disk is only supported from build 1024 if you had previously installed these disks you will not be able
to update the system using the 'System Update' option from the administration backend but the finder and only
after a fresh reboot.

[Download Locations]
TS-209/TS-209-II | TS-209 Pro/Pro-II