Help Otwarcie portu 443 w mikrotik dla Qnap

mawalach

Nowy użytkownik
Noobie
Feb 27, 2023
10
0
1
44
QNAP
TS-x53A
Ethernet
1 GbE
Witam,

mam problem z otwarciem portu 443 dla QNAP w mikrotiku chodzi żeby otwierał się w xxx.myqnapcloud w ssl. Problem polega na tym ze po jego otwarciu nie można wejsc na strony internetowe wyskakuje że połaczenie nie jest bezpieczne. Najlepsze że wtedy działa domena xxx.myqnapcloud w ssl. Jak wyłacze przekierowanie na ten port adresu qnap to wszystko wraca do normy oprócz domeny przez którą juz nie mogę zalogować sie do qnapa po ssl.
W mikrotiku w NAT otwieram port 443 dla adresu który dostaje qnap ale to blokuje mi dostęp do stron internetowych w services wyłaczyłem port 443.
Ma ktoś jakiś pomysł jak można to rozwiązac będę wdzieczny :)
 

Attachments

  • Bez tytułu.jpg
    Bez tytułu.jpg
    86.8 KB · Views: 63
IP -> Firewall -> NAT
Jako In Interface List podajesz listę interfejsów WAN lub In Interface podajesz interfejs WAN
To Addresses to oczywiście adres IP QNAP
1678481100415.png
1678481123464.png


IP -> Firewall -> Firewall rules
Nie zapomnij dodać reguły przepuszczającej port 443 przez firewall (action=accept)
1678481328021.png

albo (action=drop)
1678481412552.png
 
Witam,
dziekuje za wzkazówke lecz to nie działa jak podam In Interface WAN jak tam nic nie ma to działa strona do qnap po ssl ale nie działaja strony www
Post automatically merged:

Witam,
dziekuje za wzkazówke lecz to nie działa jak podam In Interface WAN jak tam nic nie ma to działa strona do qnap po ssl ale nie działaja strony www jak mam ustawione WAN to strony działają ale adres qnap po ssl już nie.
 

Attachments

  • Bez tytułu.jpg
    Bez tytułu.jpg
    68.7 KB · Views: 16
To wg. mnie masz zwaloną konfigurację MT lub robisz coś inaczej niż podano.
Konfiguracja działa, może być wymagane przekierowanie portu 80 jeśli nie wchodzisz od razu na stronę przez https, może drzeć japę o certyfikat ale działa.
1678539049602.png


Pokaż konfigurację interfejsów (interfejsy i listy interfejsów), konfigurację firewall-a (całego wraz z zakładką NAT) oraz QNAP (konfiguracja portów które chcesz przekierować oraz QFirewall jeśli używasz) - dane wrażliwe jak publiczny adres IP możesz zamalować.
 
  • Like
Reactions: Silas Mariusz
Przesyłam konfiguracje MT i Qnap QFirewal nie jest używany
Post automatically merged:

Przesyłam konfiguracje MT i Qnap QFirewal nie jest używany
A jeżeli chce wejsc na strone poprzez https czyli https://xxx.myqnapcloud.com:8080 to chce mnie prziekierowac xxx.myqnapcloud.com/redirect.html?count=0.12084967506574507 i na tym się zatrzymuje. Jeżeli wpisze http:// to normalnie strona sie pojawia.
 

Attachments

  • Bez tytułu2.jpg
    Bez tytułu2.jpg
    523.7 KB · Views: 26
  • Bez tytułu1.jpg
    Bez tytułu1.jpg
    282.8 KB · Views: 26
  • Bez tytułu.jpg
    Bez tytułu.jpg
    409.8 KB · Views: 26
ok zrobiłem tak jak na załaczonych obrazku lecz dalej nie mogłem wejsc poprzez adres https://xx.myqnapcloud.com na kompie podłaczonego do tej samej sieci ale sprawdziłem na telefonie i ten adres działa po https:// wydaje mi się że coś dalej mam żle w MT jak wpiszę w sieci wew. adres http://xx.myqnapcloud.com wyskakuje mi panel logowania się do MT jak wpisze po https:// to mam xx.myqnapcloud.com/redirect.html?count=0.8531070154846598 i strona nie osiągalna.
Post automatically merged:

ok zrobiłem tak jak na załaczonych obrazku lecz dalej nie mogłem wejsc poprzez adres https://xx.myqnapcloud.com na kompie podłaczonego do tej samej sieci ale sprawdziłem na telefonie i ten adres działa po https:// wydaje mi się że coś dalej mam żle w MT jak wpiszę w sieci wew. adres http://xx.myqnapcloud.com wyskakuje mi panel logowania się do MT jak wpisze po https:// to mam xx.myqnapcloud.com/redirect.html?count=0.8531070154846598 i strona nie osiągalna.
Czyli resumując adres działa po https:// z innej sieci nie działa w wew. strony www działają nie wyskakują błędy
 
ok dodałem taka regułe w NAT i dalej to samo.
Post automatically merged:

ok dodałem taka regułe w NAT i dalej to samo.
adres powinien być nie 192.168.88.254 tylko 192.168.88.230 bo to adres qnap pomyliłem ale dalej jest to samo.
 

Attachments

  • Bez tytułu.jpg
    Bez tytułu.jpg
    332 KB · Views: 16
a gdzie port ?
1678565050851.png

i pomóż sobie - dodawaj komentarze do reguł! to nie boli.
1678565120919.png

w lini poleceń dodawanie jest szybsze jak masz przykład:
1678565336703.png

Code:
/ip firewall nat
add action=masquerade chain=srcnat comment="Debian HTTPS hairpin" dst-address=192.168.88.219 dst-port=443 out-interface=bridge protocol=tcp src-address=192.168.88.0/24

1678565270207.png
 
  • Love
Reactions: Silas Mariusz
Dalej nie chce to zadziałać zrobiłem wedle instrukcji.
 

Attachments

  • Bez tytułu.jpg
    Bez tytułu.jpg
    463.1 KB · Views: 15
a masz jeszcze przekierowanie dla samego 443 ? bo to jest potrzebne ?
1678567832283.png

Post automatically merged:

i sprawdzaj w trybie prywatnym przeglądarki (just in case).
 
ok już wiem gdzie był problem jak był zaznaczony WAN to nie przepuszczało zostawiłem puste i teraz jest ok dziekuje za pomoc
Post automatically merged:

sprawdziłem w trybie prywatnym i cos jest jeczcze nie tak dalej witryna nie osiągalna po odświerzeniu normalnego trybu przegladarki dalej to samo nie osiągalna.
Post automatically merged:

ok już wiem gdzie był problem jak był zaznaczony WAN to nie przepuszczało zostawiłem puste i teraz jest ok dziekuje za pomoc
Post automatically merged:

sprawdziłem w trybie prywatnym i cos jest jeczcze nie tak dalej witryna nie osiągalna po odświerzeniu normalnego trybu przegladarki dalej to samo nie osiągalna.
 

Attachments

  • Bez tytułu.jpg
    Bez tytułu.jpg
    155.6 KB · Views: 22
  • Bez tytułu.jpg
    Bez tytułu.jpg
    352.7 KB · Views: 22
Code:
[admin@MikroTik] /ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic 

 4    ;;; Debian HTTPS
      chain=dstnat action=dst-nat to-addresses=192.168.88.219 to-ports=443 protocol=tcp dst-address-type=local dst-port=443 log=no log-prefix="" 

 7    ;;; Debian HTTPS hairpin
      chain=srcnat action=masquerade protocol=tcp src-address=192.168.88.0/24 dst-address=192.168.88.219 out-interface=bridge dst-port=443 log=no log-prefix=""

miałem ten sam błąd w przeszłości, sprawdź każdą regułe po kolei - znajdziesz winnego (robiłem to X lat temu i zwyczajnie nie pamietam).
Wyłacz hairpin i 443 , włącz tylko 443 i sprawdzaj
 
Code:
[admin@MikroTik] /ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic

 4    ;;; Debian HTTPS
      chain=dstnat action=dst-nat to-addresses=192.168.88.219 to-ports=443 protocol=tcp dst-address-type=local dst-port=443 log=no log-prefix=""

 7    ;;; Debian HTTPS hairpin
      chain=srcnat action=masquerade protocol=tcp src-address=192.168.88.0/24 dst-address=192.168.88.219 out-interface=bridge dst-port=443 log=no log-prefix=""

miałem ten sam błąd w przeszłości, sprawdź każdą regułe po kolei - znajdziesz winnego (robiłem to X lat temu i zwyczajnie nie pamietam).
Wyłacz hairpin i 443 , włącz tylko 443 i sprawdzaj
Sprawdzałem po kolei nie zlokalizowałem błędu wystarczy że włącze port 443 to nie można wejść na strony www można tylko na domene qnap po https://
Post automatically merged:

Sprawdzałem po kolei nie zlokalizowałem błędu wystarczy że włącze port 443 to nie można wejść na strony www można tylko na domene qnap po https://
Oczywiscie mówie o porcie 443 dla adresu qnap czyli 192.168.88.230
Post automatically merged:

Sprawdzałem po kolei nie zlokalizowałem błędu wystarczy że włącze port 443 to nie można wejść na strony www można tylko na domene qnap po https://
Post automatically merged:


Oczywiscie mówie o porcie 443 dla adresu qnap czyli 192.168.88.230
I problem jest tylko w sieci wew. jak podłacze się do innego routera to wszystko działa
 
Dzień dobry.
@mawalach polecam kupić taką fajną przepaskę na czoło, biała z czerwonym kółkiem - bo jesteś kamikaze. Przepuszczać port 443 na Q?
 
Dzień dobry.
@mawalach polecam kupić taką fajną przepaskę na czoło, biała z czerwonym kółkiem - bo jesteś kamikaze. Przepuszczać port 443 na Q?
To jak to mżna to zrobić inaczej żeby działało poza siecią i w sieci?
 

Users search this thread by keywords

  1. mikrotik
  2. print
  3. reverse
  4. reverse proxy
  5. certyfikat
  6. przekierowanie
  7. vpn qfirewall
  8. port forward
  9. firewall
  10. konfiguracja firewall