[PROBLEM] Pliki *.exe

Dyskusja w 'Serwer WEB i aplikacje (PHP oraz bazy danych SQL)' rozpoczęta przez użytkownika Blitzer, 23 Listopad 2009.

Ładowanie...
  1. Blitzer
    Offline

    Blitzer Nowy użytkownik Noobie

    Dołączył:
    23 Listopad 2009
    Wiadomości:
    2
    Local Time:
    13:43
    Oceny:
    +0 / 0 / -0
    Followers:
    0
    Witam!
    Właśnie stałem się szczęśliwym posiadaczem urządzenia TS-119. Postanowiłem przenieść na nie moją stronę internetową.
    Do tej pory miałem zainstalowanego xamppa. W katalogu htdocs znajdowały się pliki strony. Po kliknięciu na link na stronie zostawał uruchamiany plik *.exe. Plik znajdował się w katalogu cgi-bin xamppa. Przekopiowałem treść strony do folderu Qweb niestety po kliknięciu na link program nie wykonuje się tylko przeglądarka zaczyna ściągać ten plik *.exe na dysk. Czy na serwerze www w TS-119 znajduje się gdzieś folder cgi-bin, w którym plik zostanie wykonany? Próbowałem tworzyć folder cgi-bin zarówno bezpośrednio na dysku jak i w folderze Qweb. Niestety nie rozwiązało to problemu.

    Dzięki za ewentualną pomoc!
    Pozdrawiam!

    EDIT
    Znalazłem chyba katalog, o który mi chodziło. Ścieżka: /mnt/ext/opt/apache.
    Tutaj jest normalnie cgi-bin, htdocs itd. Udało mi się wrzucić pliki do tego cgi-bin. Niestety jak wejdę sobie w index.html, który w serwerze jest odczytywany z katalogu Qweb to nie widzi on tego katalogu cgi-bin.
    Czy da się zrobić tak, aby po wpisaniu adresu serwer www odczytywał dane z htdocs, który znajduje się w katalogu apache?
    A chcę zrobić konkretnie to: http://www.wbp.olsztyn.pl/cgi-bin/pow_s ... akwww?BM=1 :)
     
  2. Silas Mariusz
    Offline

    Silas Mariusz SysOp Administrator

    Dołączył:
    5 Kwiecień 2008
    Wiadomości:
    6 033
    Miejscowość:
    Nowy Sącz
    Local Time:
    14:43
    Oceny:
    +1 340 / 30 / -5
    Followers:
    22
    QNAP:
    TVS-x71
    Ethernet:
    1 GbE
    TVS-x71 1 GbE
    Na jakiej platformie jest skompilowany ten Twoj .exe?

    XAMPP to serwer web. Wnioskuje ze pliki .exe sa skompilowane pod Windows'em. Wiec chyba nie mozliwe jest ich uruchomienie na platformie linux'owej.

    Zreszta nie znam sie an tym. Ale na 100% bedziesz musial zamienic wbudowany serwer Web na cos innego. Popatrz na repozytorium Optware.

    Pozdrawiam
     

Poleć tę stronę