Help sonarr/rTorrent Hardlinks Question

M3Element

Passing Basics
Beginner
Aug 18, 2020
14
0
1
QNAP
TVS-x82
Ethernet
1 GbE
Is there a way to disable a folder from being hard linked in rTorrent-Pro?

I currently have sonarr and rTorrent both creating hard links which I am finding cumbersome. I know I can turn off "completed download handling" in sonarr but I would rather have sonarr make the hard-links instead of rTorrent because I use release profiles and prefer when sonarr replaces each episode instead of having 2-3 versions of an episode hard-linked in the rTorrent "complete" folder. I don't want to disable hard linking completely in rTorrent because I use it for everything else.

Within sonarr I currently have /share/Rdownload/downloads/sonarr set as my destination folder and I have tried deleting the corresponding "sonarr" folder in /share/Rdownload/complete/sonarr but it is always re-created. I know there is a way to download torrents to be ignored by media library post processing using the "seed" folder in the watch directory but I don't think that helps in my situation.

Any help would be greatly appreciated!

Firmware version: 4.5.4.1741
Model name: QNAP TVS-872N
 
1. You have to disable media library in rtorrent general settings
2. You have to disable autotools in rtorrent Advanced UI settings
Won't that disable making hard links in rTorrent for everything? I just want to disable it on a set folder as I said in my original post.
 
It's easy...
Edit: /usr/bin/rtorrent/bin/filebot-postprocess.sh
find:
Bash:
validate_label_arg


if [ "X${ARG_LABEL}" = "Xseed" ]; then
	echo "Ignoring Media Library postprocess, because LABEL is set to 'seed' only."
	exit
fi


# reissue license
/usr/bin/rtorrent/bin/filebot-available.sh

and replace if command:
Bash:
if [ "X${ARG_LABEL}" = "Xseed" ]; then
with
Bash:
if [ "X${ARG_LABEL}" = "Xseed" ] || [ "X${ARG_LABEL}" = "Xsonarr" ]; then

Where X{directory} is your desired directory...

Does this solve your issue?
 
It's easy...
Edit: /usr/bin/rtorrent/bin/filebot-postprocess.sh
find:
Bash:
validate_label_arg


if [ "X${ARG_LABEL}" = "Xseed" ]; then
	echo "Ignoring Media Library postprocess, because LABEL is set to 'seed' only."
	exit
fi


# reissue license
/usr/bin/rtorrent/bin/filebot-available.sh

and replace if command:
Bash:
if [ "X${ARG_LABEL}" = "Xseed" ]; then
with
Bash:
if [ "X${ARG_LABEL}" = "Xseed" ] || [ "X${ARG_LABEL}" = "Xsonarr" ]; then

Where X{directory} is your desired directory...

Does this solve your issue?


I am assuming this method would only work if I had "Automatically organize downloaded media content" enabled in the rtorrent general settings which I currently have disabled.

It appears all of the hard links are being created though autotools which I have enabled in rtorrent Advanced UI settings. Disabling that would stop making hard links for everything whereas I just want a specific folder to stop being hard linked.
 
Okay well, I think this can be solved very easily from GUI
/^(?!sonarr|tv).*/
upload_2021-9-21_20-16-19.png


This is classic regex.
Can you try?

if not then try:
/^sonarr.*/
 
Okay well, I think this can be solved very easily from GUI
/^(?!sonarr|tv).*/
37673.png


This is classic regex.
Can you try?

if not then try:
/^sonarr.*/


The first method appears to work but I removed the "tv" part because I still use that folder for hardlinking. The second method didn't appear to work. Thank you so much for your help!
 

Users search this thread by keywords

  1. rtorrent hard
  2. sonarr