Pomoc TS228A - Jak uruchomic i podlaczyc sie do serwera VNC w Ubuntu na Container Station

Discussion in 'Inne' started by Kamil004, Apr 6, 2019.

Loading...
  1. Kamil004
    Offline

    Kamil004 Nowy użytkownik Noobie

    Joined:
    Apr 6, 2019
    Messages:
    4
    Local Time:
    11:11 AM
    Ratings:
    +0 / 0 / -0
    Followers:
    0
    QNAP:
    null
    Ethernet:
    null
    null null
    Na poczatek witam wszystkich bardzo serdecznie.

    Posiadam QNAPa TS228A , w container station mam dodane Ubuntu LXC oraz Ubuntu DOCKER i chcialbym podlaczyc sie do ich "pulpitu".
    Znalazlem w google kilka poradnikow, np
    ForumQNAP (open)
    gdzie zawsze wszystko jest prosto opisane, oraz na samych stronach z serwerami VNC typu tight czy inne pochodne, wykonujac instrukcje instalacji tam opisane.
    Jednak w kazdym z poradnikow utykam na roznych momentach, i nie wiem co dalej zrobic, mecze sie z tym juz dobry tydzien.

    Przykladowy blad z DOCKERA:
    Show Spoiler

    vncserver
    vncserver: The USER environment variable is not set.
    root@601602fd869a:/#


    Na LXC mam cos takiego:
    Show Spoiler
    ubuntu@ubuntu-trusty-arm64-1:~$ vncserver

    Warning: ubuntu-trusty-arm64-1:1 is taken because of /tmp/.X1-lock
    Remove this file if there is no X server ubuntu-trusty-arm64-1:1
    xauth: (argv):1: bad display name "ubuntu-trusty-arm64-1:2" in "add" command
    *** Error in `Xtightvnc': malloc(): memory corruption: 0x000000001a68f120 ***
    Couldn't start Xtightvnc; trying default font path.
    Please set correct fontPath in the vncserver script.
    *** Error in `Xtightvnc': malloc(): memory corruption: 0x000000000b0bf200 ***
    Couldn't start Xtightvnc process.

    06/04/19 17:55:59 Xvnc version TightVNC-1.3.9
    06/04/19 17:55:59 Copyright C[_] 2000-2007 TightVNC Group
    06/04/19 17:55:59 Copyright C[_] 1999 AT&T Laboratories Cambridge
    06/04/19 17:55:59 All Rights Reserved.
    06/04/19 17:55:59 See TightVNC: VNC-Compatible Free Remote Control / Remote Desktop Software for information on TightVNC
    06/04/19 17:55:59 Desktop name 'X' (ubuntu-trusty-arm64-1:2)
    06/04/19 17:55:59 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
    06/04/19 17:55:59 Listening for VNC connections on TCP port 5902
    Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
    Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
    06/04/19 17:56:00 Xvnc version TightVNC-1.3.9
    06/04/19 17:56:00 Copyright C[_] 2000-2007 TightVNC Group
    06/04/19 17:56:00 Copyright C[_] 1999 AT&T Laboratories Cambridge
    06/04/19 17:56:00 All Rights Reserved.
    06/04/19 17:56:00 See TightVNC: VNC-Compatible Free Remote Control / Remote Desktop Software for information on TightVNC
    06/04/19 17:56:00 Desktop name 'X' (ubuntu-trusty-arm64-1:2)
    06/04/19 17:56:00 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
    06/04/19 17:56:00 Listening for VNC connections on TCP port 5902
    Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring
    Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
    Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring

    ubuntu@ubuntu-trusty-arm64-1:~$


    Show Spoiler

    ubuntu@ubuntu-trusty-arm64-1:~$ sudo apt-get install xfce4 xfce4-goodies
    sudo: unable to resolve host ubuntu-trusty-arm64-1
    [sudo] password for ubuntu:
    Sorry, try again.
    [sudo] password for ubuntu:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    xfce4 is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    xfce4-goodies : Depends: xfce4-battery-plugin but it is not installable
    Recommends: xfce4-power-manager but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    ubuntu@ubuntu-trusty-arm64-1:~$


    I wiele innych, dodam ze jestem noga jesli chodzi o linuxa i grzebanie w konsoli.
    Czy moglby ktos pokierowac, pokazac, czy nawet wykonac to jesli ma chwilke poprzez TeamViewera?
    Przewalilem juz tyle roznych instalacji a i tak zawsze jest cos nie tak, i przyznam szczerze ze niemam pojecia gdzie robie podstawowe bledy, bo jak mniemam nie ma tu nic skomplikowanego.

    Bede wdzieczny za pomoc i wszelakie sugestie.