Help Wymuszenie na klientach serwera DNS - Mikrotik, Pihole.

Pawliko

Main Forum Manager
Q's Professional
Feb 18, 2024
14
49
13
www.test.pl
QNAP
null
Ethernet
1 GbE
Hejka,
chce aby każdy user w mojej sieci, niezależnie od ustawień lokalnych na urządzeniu, używał mojego serwera DNS.
Sprawa wydaje sie stosunkowo prosta, wiec chwila googlowania i trafiłem na takie rozwiaznie. Wystarczy dodac wpis do firewalla na mikrotiku.

Gdzie 192.168.88.207 to Pihole,
Code:
/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.88.207 in-interface=bridge protocol=udp src-address=!192.168.88.207 dst-address=!192.168.88.207 dst-port=53 comment="piholeNAT1"
add chain=dstnat action=dst-nat to-addresses=192.168.88.207 in-interface=bridge protocol=tcp src-address=!192.168.88.207 dst-address=!192.168.88.207 dst-port=53 comment="piholeNAT2"

add chain=srcnat action=masquerade protocol=udp src-address=192.168.88.0/24 dst-address=192.168.88.207 dst-port=53 comment="piholeNAT3"
add chain=srcnat action=masquerade protocol=tcp src-address=192.168.88.0/24 dst-address=192.168.88.207 dst-port=53 comment="piholeNAT4"

No i finalnie takie roziwazanie dziala. Problem jest niestety taki, ze w samym piholu nie widze zapytan DNS dla danych klientow, ktorzy wymusili lokalnie swoje customowe adresy DNS.

Czy da sie jakos to "naprawic"?
Finalnie chce osiagnac to ze w piholu mam podglad na zapytania DNS, niezaleznie od tego czy klient uzywa automatycznego pobrania DNS z mikrotika (pihola), czy uzywa customowego serwera DNS.
Da sie to zrobic?
 
:p
a po co Ci to w ogóle wiedzieć jaki klient odpytuje dns?
niestety mi się nie udało, ale nie przejmuje się tym bo nie musze patrzeć jaki klient korzysta z dns
mało tego nie sądzę aby Twoja babcia czy mama wiedziała jak używać statyczny DNS
po za tym i tak nadchodzi era DoH'a
 
a po co Ci to w ogóle wiedzieć jaki klient odpytuje dns?
No chce monitorowac w mojej sieci takie rzeczy i tyle. :p
mało tego nie sądzę aby Twoja babcia czy mama wiedziała jak używać statyczny DNS
Ale sa urzadzenia z zahardkowanym serwerem DNS, i nie da sie tego zmienic.

po za tym i tak nadchodzi era DoH'a
To samo slyszalem 2 lata temu :p

Po drugie to nie jest odpowiedz na moje pytanie ;)
 
No chce monitorowac w mojej sieci takie rzeczy i tyle
To postaw sobie IPSa.

Ale sa urzadzenia z zahardkowanym serwerem DNS, i nie da sie tego zmienic.
Urządzenie zawsze można zmienić xD

To samo slyszalem 2 lata temu
I tu się zgodzę , poczekamy sobie na DoH - primo trzeba certy SSL aktualizować na urządzeniu .. i tutaj kończe.

podobno jak pihole jest poza adresacją głównej sieci DHCP to coś widać.
 
Ja to kiedyś rozwiązełem dodając wpisy do dnat i snat, tak jak pokazał to @Pawliko . Tylko, że na Ubi.
 
Ja to kiedyś rozwiązełem dodając wpisy do dnat i snat, tak jak pokazał to @Pawliko . Tylko, że na Ubi.
No bo finalnie to dziala, ale nie mam wpisow w PIHOLU, i tylko o to mi sie teraz rozchodzi. Zeby one tam byly :p
 

Users search this thread by keywords

  1. pihole
  2. mikrotik