Help Prośba o pomoc z połączeniem z VPN

Status
Not open for further replies.

Tomarek

Nowy użytkownik
Noobie
Jan 6, 2022
9
0
1
34
QNAP
TS-x28A
Ethernet
100 Mbps
Cześć,

piszę do was z prośbą o pomoc z konfiguracją VPN. Od 2 dni się z tym bujam ale mam nadzieję że wy mi pomożecie. Otóż idąc zgodnie z wieloma poradnikami dotyczącymi QVPN doszedłem do etapu próby połączenia się z serwerem przez VPN.
1641485162451.png

Wszystko szło dobrze aż trafiłem na problem z połączeniem się przez VPN z innego komputera. Szukałem na forach różnych rozwiązań, od zmiany UDP na TCP skończywszy na portach na ruterze (i chyba tu jest problem). Patrząc na logi z próby połączenia zdalnego mamy:

CP/UDP: Preserving recently used remote address: [AF_INET]xxx.xxx.xxx.xxx:1194
Socket Buffers: R=[131072->131072] S=[131072->131072]
Attempting to establish TCP connection with [AF_INET]xxx.xxx.xxx.xxx:1194 [nonblock]
MANAGEMENT: >STATE:1641483680,TCP_CONNECT,,,,,


Ni jak nie mogę się z tym połączyć. Obecnie korzystam z rutera D-Link DWR-921-96A1 (T-mobile) i ustawiłem port 1194 aby był otwarty:
1641485546241.png

Ale patrząc przez stronę Open Port Check Tool - Test Port Forwarding on Your Router pokazuje mi że mam zamknięty port.

Czy ktoś mógłby mnie pokierować bądź połączyć się zdalnie i za 4-paka pomóc?
 
Solution
U
Jesteś za NATem T-Mobile = nie ma adresu publicznego ... chyba że jest to wykupione łącze firmowe i odpowiednio skonfigurowane.
Z tego co patrzę to mam prywatny ponieważ mam inny IP na ruterze a inny na stronkach gdzie pokazuje Twoje IP. Ale dziwne bo na stronach które pokazują Twoje IP mam ten sam adres co skonfigurowałem na zdalnym serwerze VPN.
Co w takiej sytuacji polecacie? Czy szukać nowego operatora czy z T-mobilem starać się zmienić na adres publiczny? Albo może cos jeszcze innego?
 
Dziękuję Panowie w takim razie za pomoc i szukam nowego dostawcy :)
 
Cześć,

powracam z tematem. Udało się z dostawcą ustawić publiczny adres IP. Od początku skonfigurowałem całego VPN i teraz adres IP publiczny jest taki sam co adres serwera VPN na QNAP'ie. Udostępniłem port TCP 1194 na ruterze pod adresem IP VPN ale podczas próby łączenia nadal coś nie działa. Czy możliwe że pominąłem jakieś ustawienia w ruterze? Może jeszcze jakieś porty trzeba udostępnić?
1641553364360.png
 
I sprawdź nmapem czy faktycznie otwarte
nmap -p (numerportu) (ip)
 
Spróbuj Qbelt.
Przekieruj porty:
443 UDP
443 TCP
8080 TCP
Niestety Qbelt'em nie mogę się łączyć ponieważ laptop z którego będzie próbować się łączyć ma Win7 i appka do Qbelt'a nie działa.
Co do samych portów to zastanawiałem się wcześniej nad tym i chyba ruter z T-Mobile jest jakąś bida edyszyn i nie mam możliwości wyboru udostępniania portów pomiędzy UDP i TCP i chyba to traktuje jako jedno. Kiedyś na innych ruterach udostępniałem protokół jaki chciałem ale przy tym nie mam takiej możliwości.
 
Jeśli masz qufirewall włączonego to wyłącz go na czas testów. Ja bym podpytał dodatkowo ISP czy nie blokuje portów albo czy przekierowanie u nich jest możliwe.
 
  • Like
Reactions: Silas Mariusz
Jeśli masz qufirewall włączonego to wyłącz go na czas testów. Ja bym podpytał dodatkowo ISP czy nie blokuje portów albo czy przekierowanie u nich jest możliwe.
Wall'a nie mam włączonego. Ale mam inny port do QNAP'a ustawiony, może tu jest błąd?
 
Jak nie zrobisz skanu portów, to skąd chcesz wiedzieć co jest nie tak?
 
Z tego co patrzę to mam otwarte tylko 23, 80 i 443. Wiec problem jest z portami. W takim razie jak mogę inaczej odblokować port na ruterze skoro mam:
1641558727917.png
 
Zakrywasz IP serwera, które jest w sieci lokalnej - nikt Ci tak nie "pohakuje" Twojej sieci. Nie wiem co za router, więc poszukaj w internecie, dlaczego nie działa przekierowanie.
 
ok, w takim razie DWR-921-96A1. Niby robię wszystko wedle instrukcji ale nie chce to pójść :/ Może jakoś możemy się połączyć zdalnie?
Post automatically merged:

Ktoś jest w stanie pomóc?
 
To problem z routerem, nie z Qnapem. Wywal DWR-921-96A1 i kup router :)
 
  • Like
Reactions: jerry1333
Udało się rozwiązać problem:)

Udało się wszystko skonfigurować. Powodem był ruter. Nie chciał przyjąć przekierować portów ale zrobiłem mu twardy restart(do ustawień fabrycznych) i po ustawieniu wszystkiego na nowo ruszyło :)
 
Status
Not open for further replies.

Users search this thread by keywords

  1. port forwarding
  2. publiczne ip
  3. qvpn