Help Problem z szybkością transferu z PC do NAS i odwrotnie po WiFi 10-11 Mb/s

Gregorson

Nowy użytkownik
Noobie
Jun 26, 2024
9
3
3
44
QNAP
null
Ethernet
802.11ax (Wi-Fi 6)
Witam,
Mam QNAP TS-262 podpięty do rutera TP-Link Deco x50, komputer jest połączony za pomocą karty sieciowej WiFi 6.
Internet mam od firmy Toya - 1 GB/s łącze z firmowym modemem firmy Huawei.
Po pierwszym uruchomieniu miałem transfery rzędu 50-60 MB/s ale po kilku dniach spadły do 10-11 Mb/s.
Przeczytałem na tym forum, że trzeba podpiąć NAS i komputer pod switch i powinno śmigać, ale pomimo takiego podłączenia nic się nie zmieniło. Ustawienia na karcie sieciowej po kablu na 1 GbE.
Szukałem wszędzie rozwiązania ale nie mogę znaleźć.
Może ktoś może podpowiedzieć czy to problem z ustawieniami czy coś innego?
 
Testy u mnie: 2.4/5G X50-POE (2.5G ETHERNET)
Laptop wifi: Intel WiFi 6 AX200
Bash:
Connecting to host 10.85.0.10, port 5201
[  5] local 10.85.0.52 port 42008 connected to 10.85.0.10 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec   119 MBytes  1.00 Gbits/sec    0   2.42 MBytes      
[  5]   1.00-2.00   sec   145 MBytes  1.22 Gbits/sec  664   1.77 MBytes      
[  5]   2.00-3.00   sec   135 MBytes  1.13 Gbits/sec    0   1.91 MBytes      
[  5]   3.00-4.00   sec   141 MBytes  1.18 Gbits/sec    0   2.03 MBytes      
[  5]   4.00-5.00   sec   144 MBytes  1.21 Gbits/sec    0   2.20 MBytes      
[  5]   5.00-6.00   sec   145 MBytes  1.22 Gbits/sec    0   2.30 MBytes      
[  5]   6.00-7.00   sec   124 MBytes  1.04 Gbits/sec   81   1.69 MBytes      
[  5]   7.00-8.00   sec   139 MBytes  1.17 Gbits/sec    0   1.79 MBytes      
[  5]   8.00-9.00   sec   148 MBytes  1.24 Gbits/sec    0   1.85 MBytes      
[  5]   9.00-10.00  sec   141 MBytes  1.18 Gbits/sec    0   1.90 MBytes      
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.35 GBytes  1.16 Gbits/sec  745             sender
[  5]   0.00-10.01  sec  1.35 GBytes  1.16 Gbits/sec                  receiver

iperf Done.

# SMABA zamontowane w fstab
$dd if=/dev/zero of=1G.dump bs=1G count=1
# Na serwer
$rsync --progress 1G.dump /media/nas/home
1G.dump
 1.073.741.824 100%  174,74MB/s    0:00:05 (xfr#1, to-chk=0/1)  # z 300 spada do 174
# Z serwera
$rsync --progress /media/nas/home/1G.dump .
1G.dump
 1.073.741.824 100%  137,30MB/s    0:00:07 (xfr#1, to-chk=0/1) # od 120 wygrzewa się i do 137

Mogę się mylić ale koledzy mnie poprawią jeżeli się mylę MTU jest rzeczą którą powinieneś się zainteresować tylko u mnie zawsze to wygląda tak ze niby benchmarki lepsze a zaczynają się inne problemu.

Dlatego co mogę łączę kabelkami
 
Nie wiem czy dobrze sprawdzam, ale pokazuje mi prędkość sieci WiFi na poziomie 1200 Mbps do 2100 Mbps
 
Testy u mnie: 2.4/5G X50-POE (2.5G ETHERNET)
Laptop wifi: Intel WiFi 6 AX200
Bash:
Connecting to host 10.85.0.10, port 5201
[  5] local 10.85.0.52 port 42008 connected to 10.85.0.10 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec   119 MBytes  1.00 Gbits/sec    0   2.42 MBytes     
[  5]   1.00-2.00   sec   145 MBytes  1.22 Gbits/sec  664   1.77 MBytes     
[  5]   2.00-3.00   sec   135 MBytes  1.13 Gbits/sec    0   1.91 MBytes     
[  5]   3.00-4.00   sec   141 MBytes  1.18 Gbits/sec    0   2.03 MBytes     
[  5]   4.00-5.00   sec   144 MBytes  1.21 Gbits/sec    0   2.20 MBytes     
[  5]   5.00-6.00   sec   145 MBytes  1.22 Gbits/sec    0   2.30 MBytes     
[  5]   6.00-7.00   sec   124 MBytes  1.04 Gbits/sec   81   1.69 MBytes     
[  5]   7.00-8.00   sec   139 MBytes  1.17 Gbits/sec    0   1.79 MBytes     
[  5]   8.00-9.00   sec   148 MBytes  1.24 Gbits/sec    0   1.85 MBytes     
[  5]   9.00-10.00  sec   141 MBytes  1.18 Gbits/sec    0   1.90 MBytes     
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.35 GBytes  1.16 Gbits/sec  745             sender
[  5]   0.00-10.01  sec  1.35 GBytes  1.16 Gbits/sec                  receiver

iperf Done.

# SMABA zamontowane w fstab
$dd if=/dev/zero of=1G.dump bs=1G count=1
# Na serwer
$rsync --progress 1G.dump /media/nas/home
1G.dump
 1.073.741.824 100%  174,74MB/s    0:00:05 (xfr#1, to-chk=0/1)  # z 300 spada do 174
# Z serwera
$rsync --progress /media/nas/home/1G.dump .
1G.dump
 1.073.741.824 100%  137,30MB/s    0:00:07 (xfr#1, to-chk=0/1) # od 120 wygrzewa się i do 137

Mogę się mylić ale koledzy mnie poprawią jeżeli się mylę MTU jest rzeczą którą powinieneś się zainteresować tylko u mnie zawsze to wygląda tak ze niby benchmarki lepsze a zaczynają się inne problemu.

Dlatego co mogę łączę kabelkami
Tylko, że nie bardzo mam jak podpiąć komputer pod kabel tak na stałe. Rozciągnąłem jednak kabel między switchem a komputerem do testu i także nic się nie zmieniło transfery cały czas na poziomie 10-11 Mb/s
Post automatically merged:

jaka jest prędkość między routerem a switchem ?
jaka jest prędkość sieci WIFI raportowana przez komputer ? How to determine Wi-Fi and Ethernet connection speed on Windows 10
Jak sprawdzić prędkość między ruterem a switchem?
 
Dobra,

to teraz opowiedz, jakie transfery może zapewnić Ci switch / router po kablu ?

1 Gb czy 2,5 Gb ?

Mam na myśli połączenie kablowe, WiFi zostaw na razie w spokoju.

S.
 
1 Gbit ;) Czyli standart.

Nie myl pojęć proszę, raz piszesz :

"50-60 MB/s ale po kilku dniach spadły do 10-11 Mb/s."

Raz są MB/s, potem Mb/s, to różnica o rząd wielkości (10x).


Link: https://i.imgur.com/u40eQwo.png


Wiem, to tylko różnica : mała czy duża litera, ale ma to kolosalne znaczenie.

Domyślam się, że to, co widziałeś wcześniej, to była jakaś chwilowa ekspozycja, pliki dopiero się ładowały, więc transfery mogły wyglądać na wyższe.

Ale pewnych rzeczy nie przeskoczysz, 1Gbit = 100 MB transferu, musisz pamiętać o sumach kontrolnych w protokole.

S.
 
Masz rację przepraszam źle napisałem, transfery są na poziomie 10-11 MB/s
Czyli przy 1Gb nie powinny być jednak wyższe?
Tak jak napisałeś coś w okolicach 100 MB?
 
Teoretycznie tak...

Ale to zależy od wielu czynników, począwszy od dysków w NAS, kablach do routera (ich jakość, długość itp).

Wracając do dysków ... Dane masz na HDD, gdy robisz test ? Czy na SSD ? A może na m.2 ?

Tu są często różnice idące o rzędy wielkości...

Odczyt z dobrych dysków HDD to 120-130 MB/s

SSD potrafią dać tu już 520-550 MB/s

A dyski m.2 od 3.500 przez 7,000 do nawet 15,000 MB/s, ale to zależy od dysku, typu złącza na płycie głównej i samej implementacji softwaru.

Zrobiłem test na małym kompie :


Link: https://i.imgur.com/Splx7NZ.png


Szału nie ma, w domu na stacjonarce mam dużo lepsze wyniki, ale dalej jest wiele niewiadomych.

Możesz mieć switcha / router z prędkościami na kablu 1 Gb/s, ale ... połączenie jest tylko na 100 Mb/s.

Może tu należy zajrzeć najpierw ?

S.
 
Podpowiedziałeś mi o kablu i teraz sobie przypomniałem, że przestawiałem NAS w inne miejsce ale użyłem innego kabla niż wcześniej ( wcześniej był podpięty kablem który był w zestawie) i te lepsze transfery były właśnie przed przeniesieniem samego QNAPa. Teraz podpięty jest jakimś kablem który nawet nie wiem jakiej jest kategorii .Jutro sprawdzę kable i zobaczę czy to nie to.
Na tą chwilę dziękuję za pomoc, dam znać czy pomogło.
 
po prostu sprawdź jaka jest prędkość połączenia w samym NASie
1719469355681.png
 
Zmieniłem kabel i transfery od razu podskoczyły do 60-70 MB/s więc problem został rozwiązany. Dziękuję wszystkim za pomoc, można zamknąć wątek.
 
  • Like
Reactions: Silas Mariusz
dużo lepiej .. ale ja bym oczekiwał koło 100 .. w zależności co przesyłasz po sieci (jak duże pliki).
 
  • Like
Reactions: wac_ns
No w porównaniu do 10-11MB/s to jednak jest różnica. To jest transfer na PC podpiętym za pomocą WiFi, nie na kablu. Zamówiłem już nowe kable cat7 więc jak przyjadą to powymieniam jeszcze między ruterem a modemem i wtedy sprawdzę.
 
Brawo ty, tak trzymaj.

Cat7 to w domowych zastosowaniach aż nadto, ale jak masz zmieniać, to nie tylko router - modem, ale też nie żałuj do NAS'a ;)

Daj znać, jakie są transfery po wymianie kabli, ale przede wszystkim skąd jest ten transfer ? HDD, SSD czy m.2 ?

Pozdrawiam,

S.
 
Cat7 faktycznie to może trochę za dużo ale, akurat znalazłem w dobrej cenie. Wymieniłem, między głównym ruterem a modemem, między głównym ruterem a NASem oraz między głównym ruterem a drugim ruterem (mam system mesh). I transfery podskoczyły do 110 MB/s na WiFi. Oczywiście zależy od wielkości plików, ale takie szybkości są bardzo często. Bardzo dziękuję wszystkim za pomoc i dobre rady 😊
Post automatically merged:

W NAS mam zamontowane dwa dyski HDD Seagate ironwolf oraz jeden m2 250 GB jako zwiększenie pamięci do szybszego pobierania danych z NAS.