Help Problem aktualizacji firmware

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Witam serdecznie.
Od pewnego czasu borykam się z problemem aktualizacji firmwaru na urządeniu TVS-473.

Dostaję błędy typu:
Błąd 2022-08-21 22:46:21 admin 127.0.0.1
Firmware Update Firmware Update [Firmware Update] Failed to update system from version 5.0.0.2055 to 5.0.0.2131.
A flash read/write error occurred. Error code: FW014


Błąd 2022-08-21 22:46:21 admin 127.0.0.1
Firmware Update Firmware Update [Firmware Update] Failed to update system. Error code: FW999

Czasem któraś z kolejnych prób zadziała. Irytuje mnie fakt ciągłego borykania się z tym problemem.
Zastanawiam się jak to można samemu rozwiązać.

Pomyślałem, że może pomóc instalacja bez dysków i o dziwo poszło, więc zainicjowałem od nowa macierz w RAID 10.
Miałem nadzieję, że kolejny update wykonam już poprawnie z QTS`a. Niestety problem nadal istnieje.
Problemy te mam od samego początku zaraz po zakupie i pierwszej aktualizacji firmware.
Zakładałem, że któraś kolejna aktualizacja naprawi problem ale niestety, nadal problem istnieje.

Chciałem ściągną firmware 4.3.3 aby wgrać oryginalny startowy i spróbować wszystko od nowa.
Nigdzie nie mogę go namierzyć.

Czy naprawdę nieliczni mają taki problem? Szukałem już informacji na ten temat ale żadna z nich nie wydaje mi się być w 100% skuteczna, a nie chciałbym skopać urządzenia całkowicie.
Dodam że z linuksem mam do czynienie więc nie jest to problem i mogę ruszyć naprawę z konsoli ale nie wiem od czego zacząć.
Mam wrażenie, że każde z tych urzązeń TS, TVS i inne mają inne ułożenia partycji i ich montowanie, a pewnie każda wersja firmware dodatkowo wprowadza zmiany w ustawieniach partycji.

Proszę o jakieś wskazówki, a może ktoś rozwiązał już te problemy?
 

pigers

Long live Pr0xM0x
Administrator
Jul 26, 2013
13,644
40
2,324
230
www.buymeacoffee.com
QNAP
QuTScloud
Ethernet
100 GbE
  • ·
  • QuTScloud
  • ·
  • 100 GbE
  • ·
  • Ten którego QNAP jeszcze nie ma ! Najnowszy na Debianie !
zrób ticketa do qnap przez aplikację helpdesk - nei zapomnij załączyć logów
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Tak, myślałem o tym ale czy będę musiał konfigurować firewall w routerze i qunapie?
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Heh, tak. Chodziło o to, że pomoc będzie się łączyć zdalnie i to może być problem.
Zrobię backup i postaram się samemu naprawić owy problem, jak ustalę co dokładnie należy wykonać, na pewno umieszczę tu stosowne informacje.
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Do tego zmierzam. Dzięki za linki postaram się z nich skorzystać. Na razie leci backup i przeniesienie wirtualnych środowisk na inną maszynę.
 
  • Like
Reactions: jerry1333

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Znacie jakieś linki do pobrania firmware w wersji 4.3.3 dla urządzenia TVS-473.
Ewentualnie plik z recovery?
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Odpowiedź z działu technicznego QNAP:

Panie Rafale wszystko wskazuje na usterkę modułu DOM - Disk on Module. DOM jest na płycie głównej w postaci USB - może być on na stałe.

Proszę spróbować uruchomić serwer na czystym testowym dysku i zobaczyć czy problem występuje. Jeśli nie, tzn. że usterka może dotyczyć systemu operacyjnego na obecnej konfiguracji dyskowej - mało prawdopodobne, zwłaszcza, że mówi Pan, że problem również występuje bez dysków.

Jeśli jednak problem zacznie występować + fakt, że problem występuje również bez dysków, to jestem przekonany, że usterka dotyczy DOM'a.

Taka awaria może oznacza uszkodzenie urządzenia. Niestety urządzenie nie jest już na gwarancji. Proszę spróbować skontaktować się z dystrybutorem tego urządzenia firmą FEN i porozumieć się w sprawie naprawy (wymiana DOM).
Post automatically merged:

Czy samemu jestem w stanie naprawić DOM?
Na moje oko problem leży w montowaniu zasobów podczas aktualizacji oprogramowania.
Zastanawiam się nad zmianą urządzenia, a stare spróbowałbym samemu naprawić.
Pytanie tylko czy z pamięcią DOM jestem w stanie coś zrobić.
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Wykonałem aktualizację jako admin z konsoli SSH po zalogowaniu się.
Dostałem błędy:

cksum=3071036418
Check RAM 2 space available for FW update: OK.
Code signing check: Before PC1
Using 120-bit encryption - (QNAPNASVERSION4)
len=1048576
model name = TS-X73
version = 5.0.0
decrypting...
extract digital signature into /tmp/cs_fw_signature.sign...
digital signature found, size is 2499
IS_64BITS
IS_STORAGE_V2
QY03ED20.BIN
boot/
bzImage
bzImage.cksum
bzImage.sign
config/
ec_force_boot
fw_info
fw_info.conf
initrd.boot
initrd.boot.cksum
initrd.boot.sign
libcrypto.so.1.1
libssl.so.1.1
qpkg.tar
qpkg.tar.cksum
qpkg.tar.sign
rootfs2.bz
rootfs2.bz.cksum
rootfs2.bz.sign
rootfs_ext.tgz
rootfs_ext.tgz.cksum
rootfs_ext.tgz.sign
update/
update_ec.conf
update_ec.sh
update_img.sh
5.0.0 20220815
Code signing check: After PC1
Code signing check: Daemons exist
Code signing check: fp_status=0 cert_status=0
Code signing check: Before clean file
Code signing check: After clean file
MODEL NAME = TS-X73,new version = 5.0.0
limit version = 3.7.2
Allow upgrade
Allow upgrade
Check HDA_ROOT free size for save qpkg.tar: OK.
/mnt/update
1+0 records in
1+0 records out
512 bytes (512B) copied, 0.000032 seconds, 15.3MB/s
tune2fs 1.45.5 (07-Jan-2020)
/sbin/tune2fs: Read-only file system while trying to open /dev/sdc6
Couldn't find valid filesystem superblock.
Update image using HDD ...
bzImage cksum ... Pass
initrd.boot cksum ... Pass
rootfs2.bz cksum ... Pass
rootfs_ext.tgz cksum ... Pass
rootfs_ext.tgz cksum ... Pass
qpkg.tar cksum ... Pass
Update RFS1...
mke2fs 1.45.5 (07-Jan-2020)
/dev/sdc2 contains a ext2 file system labelled 'QTS_BOOT_PART2'
created on Thu Jun 23 23:09:20 2022
/dev/sdc2: Read-only file system while setting up superblock
mount: block device /dev/sdc2 is write-protected, mounting read-only
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/bzImage': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/bzImage.cksum': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/bzImage.sign': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/initrd.boot': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/initrd.boot.cksum': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/initrd.boot.sign': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/rootfs2.bz': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/rootfs2.bz.cksum': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/rootfs2.bz.sign': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/rootfs_ext.tgz': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/rootfs_ext.tgz.cksum': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/rootfs_ext.tgz.sign': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/qpkg.tar': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/qpkg.tar.cksum': Read-only file system
/bin/cp: cannot create regular file `/root/FLASH_RFS1/boot/qpkg.tar.sign': Read-only file system
Checking bzImage ... Failed.
[Firmware Update] System update failed. Error code: FW999
 

RafalLenarczyk

Passing Basics
Beginner
Nov 9, 2016
10
1
3
45
QNAP
TS-x73
Ethernet
1 GbE
Wykonałem aktualizację jako admin z konsoli SSH po zalogowaniu się.
Dostałem błędy:
/sbin/tune2fs: Read-only file system while trying to open /dev/sdc6
Read-only file system i tu jest błąd - próba aktualizacji ale nie może zapisać bo read only
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Rozwiązałem problem :)

Proces naprawy przeprowadziłem według znalezionej dokumentacji na stronie:
Firmware Recovery Guide for x86 based NAS

Na początku wyjąłem wszystkie dyski HDD i SSD M.2
Ważne aby nie pomylić ich kolejności i włożyć je po całej akcji naprawczej w te same sloty.
  1. Aplikacją RUFUS należy przygotować pendrive z clonezilla-live-3.0.1-8-amd64
  2. Ściągnąłem pełny obraz recovery wersja 1.3.0: https://eu1.qnap.com/Storage/tsd/fullimage/F_TVS-X73_20160908-1.3.0.img podany na w/w stronie dla urządzenia TVS-473
  3. Następnie należy skopiować ściągnięty obraz na wcześniej przygotowany pendrive i po skopiowaniu zmienić jego nazwę na dom.img
  4. Uruchamiamy QNAPa z przygotowanego pendrive zmieniając kolejność bootowania w bios.
  5. Uruchamiamy Clonezlilla do opcji wydawania poleceń z linii komend.
  6. Teraz nadszedł czas na skopiowanie pliku dom.img do naszego DOM_FLASH:
    1. sudo su
    2. fdisk -l (lokalizujemy nasz DOM u mnie to był /dev/sda)
    3. cd /lib/live/mount/medium/
    4. cp dom.img /dev/sda
    5. reboot
  7. Wyciągamy pendrive USB i uruchamiamy urządzenie, wejdzie w taki tryb TEST.
  8. Jak już się odpali lokalizujemy urządzenie przy pomocy QFinder`a i wgrywamy nowy soft. Dla pewności wgrałem ponownie ten sam który miałem wcześniej aby nie zaburzyć zgodności z dyskami wcześniej używanymi.
  9. Po wgraniu tego samego softu wyłączamy urządzenie i wkładamy dyski do tych samych slotów.
  10. Uruchamiamy (w moim przypadku zachowałem wszystkie ustawienia i dane) i wykonujemy w webowej wersji kolejny upgrade firmware do najnowszej wersji.
Tym razem proces przebiegł poprawnie i urządzenie zostało zaktualizowane.
Pytanie tylko czy następne aktualizacje też wykonają się poprawnie, mam jednak nadzieję, że proces domknął się do końca i udało się z podmienić DOM.

PS. Chciałem podmienić DOM na pednrive podłączany za pomocą kabla USB ale nie chciał się uruchomić pomimo że przygotowałem go w poprawny sposób. Być może z bootloaderm było coś nie tak.
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Super, prawdę mówiąc okaże się przy następnych aktualizacjach, aczkolwiek wydaje mi się, że problem został rozwiązany.
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Witam, ponownie.
Sytuacja wygląda tak. Dzisiaj pojawił się nowy update, okazja do przetestowania.
Ku mojemu zdziwieniu nadal ten sam błąd. Można stwierdzić iż pomimo wcześniej wykonanych kroków nadal występują problemy.
 

rafko

Entry Technician
Q Associate
Dec 13, 2013
53
12
8
QNAP
TVS-x73
Ethernet
802.11ad
Czyli jak coś to zapraszam do kontaktu na jeśli byłby Pan zainteresowany naprawą :)
Pewnie, jestem zainteresowany. Na początek musze kupić drugie urządzenie na podmiankę gdyż jest mi niezbędne.